Achievement unlocker not working


Today I tried the achievement unlocker again, but somehow it doesn’t load my profile. I have the XBL profile on an USB stick, it is recognized as such, as I can sign and rehash, just when I open the achievement unlocker, it remains blank. I could try to ‘’ open’’ the profile using the button, but the profile won’t show inside my USB drive content? I am using Windows 10, if that makes a difference? Anyone found a fix for this? I looked around but I seem to be the only one. I just renewed Diamond sub, but this way it’s not really worth it for me…

I cant seem to drag and drop to my profile for any editing or game adding

Fixed it. Don’t know if it was because of Windows 10 or something else (update from Xbox?) but somehow the content of the USB stick seems to be empty now. You have to manually search in Horizon for your profile, then copy it to your hard drive, make the changes you want, then inject the file on your hard drive back to the usb stick using Horizon, and it works like a charm.

Thanks for the help… :wink: