Age of Wonders III Cheats and Trainer for Steam

Age of Wonders III
This is the official discussion topic of the Age of Wonders III Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Money
2. Unlimited Population
3. Unlimited World Movement
4. Unlimited Mana
5. Instant Research
6. Unlimited Cast Points
7. God Mode
8. Unlimited Battle Movement


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 08/12/2019
    Started development

  • 08/15/2019
    Released trainer with 8 cheats



Like what you see?

Check out all of the games WeMod supports here.

The Age of Wonders III cheats have been updated!

Changes:

  • Released trainer with 8 cheats



Please post in this topic if you run into any issues!

1 Like

When I try to use the trainer, it’ll launch the game, and the game works fine, but then WeMod says it cannot find the game.

That’s an odd bug, glad it isn’t impacting the use of the trainer. @frank can take a look when he gets a chance

Cant get it to work when I click play.

Can you please be a little more specific? Thanks! :slightly_smiling_face:

Every time I start age of wonders 3 and click on play in your age of wonders 3 trainer it tries to connect. Then a window pops up reading "There was a problem starting the trainer. Your game version may not be compatible. You can also try again at a different point in your game.:

Please try starting the game manually and then ALT-Tabbing and selecting play in the WeMod app! :slightly_smiling_face:

No good. I dont think the app is up to date with the game? I also bought the base game then all the DLC, but that probably doesnt matter. vl.802 - build : 28623

i just found out that you may be playing with the debug on

i had the same problem and the game, when in debug mode does not have the same name as an application

I just checked…its not in debug mode. Maybe they updated the game?

I doubt it, it works perfectly for me. Make sure that your game is up to date.

I also had a problem with bitdefender that destroy de trainer from wemod but that was easily solved.
The debug mode was the solution for me, i do not know enough pass that to help you, im sorry

Mostly works still- unlimited cast points doesn’t work as far as I can see, in or out of combat, but the rest does what it says for the most part. The ‘unlimited mana’ one does, however, lock mana at 500… which isn’t actually enough for some things.

good trainer :slight_smile:
can we please get a cheat for instant unit creation?

Old game but uh, Instant Research & Cast doesn’t work.

Couldn’t get this to work. Keeps stating “We’re having trouble starting or finding your opened game.” Tried starting first from Steam and starting from the trainer, no luck.

Trainer can’t find game even though its running.

I have the same problem. I even tried to make a path straight to the file, and it didn’t work.

Working all ok here, no issues at all

Instant Research & Unlimited Cast Points does not work, other than that, pretty solid trainer. Can you fix those 2 as well?