Any fix for an "invalid STFS package"?

I’m trying to inject a different system preferences file in Horizon, but I keep getting this error, and I have been unable to find any direct support for how to fix this. Unfortunately, this is quite literally the only save file I can find for Ninja Gaiden 2 mission mode (niche game to begin with, DLC even more so, it’s not for the Sigma 2 version), there isn’t anything else I could try. I’ve had no other issues in injecting other game files into Horizon, it just happens to be this one. Quick Fix isn’t working either, I get the “Not a valid CON STFS package” error. The package manager method is also telling me “a device attached to the system is not functioning”.

Using this save file here for Gold survival medals, mentor & MN of missions, all 3 of these are giving me the same error.

It’s worth mentioning that I’m a novice when it comes to Horizon, so I’m not sure if I’m doing anything wrong.


1 Like

Technically we don’t provide support for horizon as it is retired but if @Chris is available and has some insight he will give you his input

There are 2 possibilities here

  1. You need to use the package manager and inject those into your save
  2. They aren’t saves for Xbox at which point you can’t do anything with them
1 Like
  1. I tried the package manager already, and it gave me the “a device attached to the system is not functioning” error. I’ve tried out multiple USBs to see if that would change, but nothing did
  2. Ninja Gaiden 2 is an Xbox 360 exclusive (it’s not possible to have files from a different platform), and the files I downloaded match up to be identical formats for what I already had on my save.

Going on from point 2, I’ve had a quick look at the save files and it seems both the Gamesave.Dat is named exactly the same as the extracted data from the gamesave. It seems likely that what you’re trying to open in Horizon is this data. Open a gamesave.dat and overwrite/inject this file into the gamesave using the package manager as Chris mentioned. Save/Rehash/Resign and copy back to your usb device.

If I’m following you correctly, the actual save data doesn’t matter at all to me (I’ve beaten everything for that legitimately beforehand), it’s the system preference file that I need (Ninja Gaiden 2 is identical to Ninja Gaiden 3 in this regard, where the optional missions are tied to the system preferences file while the story is separate from that. I have successfully injected new NG3 save slots and system preferences before). Files with names like ng2stryd07 are saves only for the story of the game, the DLC missions are saved to the ng2sysd.dat file, which isn’t wanting to inject, and package manager isn’t even wanting to work for me. I’ve tried multiple USBs for it but I keep getting the error “a device attached to the system is not functioning”.

6, 9, and 10 are the only ones I need from this: NG2 DLC (54.6 KB)

try this

I get the same error about the device even thought im loading it directly from the desktop, so there definitely is an issue somewhere. Just rehash/resign with you profile/console id and give it a test lad

Well, these are at least injecting properly without any issue, and I have no issues putting in the console ID and other things and rehashing. However when I boot it up on my 360, it’s telling me “System Preferences: This saved game is damaged.” I’ve tried quick fix as well for these, but still the same issue. Normally when this happened to me, it’s because it hasn’t rehashed properly (I ctrl + a and ctrl + v everything), but I’ve done 6 and 9 multiple times, but it’s still the same.