App stuck on "Loading Mods" no matter what game

Hello,

I know many people have posted this issue in the past. For me this just cropped up today. Tried several uninstalls/reinstalls. Added exceptions to my firewall and anti-virus. Followed the steps in the linked “failed to load mods” topic you guys typically link to this issue. I am not on a public network I am on my own home network. I have tried custom path. I have tried running with firewall and anti-virus completely disabled. I have tried loading into an already-launched game. I have tried launching a game with wemod and it won’t even start the process of launching the games. It appears to be completely non-funtional.

Any other possible solutions?

EDIT (Additional Info): I believe the issue is with it failing to download the trainers. When I go to “C://Users/myname/appdata/roaming/wemod/app/downloads/trainers” it has the file for the trainer but it reads as “0kb”. Its downloading and empty trainer. I have also completely uninstalled and disabled all firewall and anti-virus and ran as admin at this point.

Hello and welcome back to the community! :slight_smile:

Could you give us an example of which games you tried and where you got those from?

And then:

  1. Attempt to use a trainer in a game by pressing the Play button.
  2. When it fails, go to your settings by clicking the cog wheel in the top-right corner of WeMod.
  3. You’ll see an option there to download a log. Do that then upload it to a reply in this thread (there’s an upload button on the toolbar when you reply).

Thank you. :slight_smile:

Hi @Ravenfyre , I encountered the same problem. It started around two weeks ago (until then it worked perfectly), so i thought it was some temporary error. But it still is not working and I see someone has the same problem, so I will try to add some more insight on it.

As the @N80926 , the problem is when I am launching game WITH mods, the loading button goes animating infinitely, never stops or pop error screen. But the game won’t start, even the launcher is not starting (I tested Rockstar launcher and Steam). I have to manually close the app. It even asks me, if I want to close the app when there are mods currently running (screenshots), which is not true :smiley: , I include screenshots from Kaspersky and Windows Defender exclusions, but I don’t think it is caused by antivirus, because even deactivating both antivirus software haven’t solved the problem.
When I launch the game without mods with WeMod, the game launches correctly.

I have logs from few games I have currently installed - Police Simulator: Patrol officer (Steam) - I have logs when launching with and without mods.
Hogwarts Legacy (Steam - launching with mods)
GTA V (R* launcher - launching with mods)

Please help us, I love WeMod and this is very annoying :smiley:

Screenshots:




Logs:
GTAV_rockstarlauncher_withMODS.log (23.8 KB)
HogwartsLegacy_withMODS.log (24.0 KB)
PoliceSimulator_withMODS.log (22.5 KB)
PoliceSimulator_withoutMODS.log (22.3 KB)

Thank you very much in forward and hope we get this working again!
@ladisnek

EDIT:
Same as @N80926 I have zero sized trainers in download folder:
trainers

EDIT 2:
Tried adding exclusion in Windows Firewall for both incoming and outgoing traffic, but doesn’t changed anything.

EDIT 3:
Just to be sure, all the games are bought through official channels. Not pirated.

EDIT 4:
I went brutal and unistalled WeMod, deleted Local and Roaming App folders of WeMod, then I deleted every Registry key and folder containing “WeMod” and installed fresh install of WeMod. But nothing happened, even if I whitelisted WeMod in firewall, deativated antivirus and performed completely clean install, it doesn’t work.