Aven Colony Cheats and Trainer for Epic Games

Aven Colony
This is the official discussion topic of the Aven Colony Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Nanites
2. Unlimited Water
3. Unlimited Food
4. Instant Construction
5. Unlimited Battery Energy


Trainer Video:

Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 11/04/2021
    Started development

  • 11/04/2021
    Released trainer with 5 cheats

Like what you see?

Check out all of the games WeMod supports here.

1 Like

The Aven Colony cheats have been updated!


  • Released trainer with 5 cheats

The unlimited resource cheats take forever to actually go through, on campaign

None of the cheats work.

Unlimited battery energy doesn’t work.
Unlimited water and food - you still need to build pumps and farms/greenhouses, 'cause citizens are unhappy due to consumption

Instant Construction stop at 100%. Only way to fix it is to turn it OFF and ON again for the construction to finish.
Unlimited Battery Energy doesn’t work.

Unlimited battery energy works fine. You need to enable the cheat then click on each battery.

Unlimited Nanites - Works.
Unlimited Water - Works.
Unlimited Food - Works.

Instant Construction - Works momentarily then get stuck at 100%.
You can turn it off and on again but it’s better off deactivated at this point.

Unlimited Battery Energy - Works 2 ways.
First method, leave it connected to the base and always click each battery and repeat.
Second method, Construct battery detached from the base, turn off automatic shutoff and turn on the battery.

Would it be possible to add the option to max out morale? This would help with some missions were you need to reach a special amount of morale (and this can become annoying af).

I have tried using the ‘newly added’ cheats for this game and continually get a message which tells me the cheats are for the 32 bit version and I am running the 64 bit version. I have owned a copy of this game for over 1 year and , as far as I can discover (and according to Mothership), there has never been a separate 32 bit version, it was always a 64 bit game. WeMod have tried to resolve this problem for 10 days and have now referred me to you. can you help, please?

Unlimited Food/Water sort of destroyed my game. The water took up all my storage space, and I couldn’t Shift-Click it to delete any (deleting food worked). I turned of all water generating structures. The citizens wouldn’t drink the water, and it never went down; no way at all to get rid of it.

Restarting the game, reloading the save, nothing helped.

Maybe try adding a +1000 food/water or something, rather than the crazy amount it currently adds. That seems to break the save altogether.

Been wanting to try this trainer, but 3 days later it refuses to install, goto to setup log error, and there is no setup log to goto, as well and it puts a folder in app data local, but adds nothing in the roaming folder. windows def av is permanently shut off, abover folder removed more than once, 10 reboots, same error over and over whether it is dl the installer or the full offline installer, it all chokes at the setup log error… thank you for any assistance you can offer

It runs fine on epic games for me. I have an x86 bit

I also have the Epic version. I have just uninstalled it, cleaned the registry, reinstalled it - and still get the 64bit/32bit message.

Appreciate the good work done for the trainer.

Works very well on epic.

Kindly adjust the unlimited food to 10k or 100k instead of 1k.
And possibly unlimited storage to compliment it.

Colony keeps having food shortage issue lol.

Finally resolved the issue. Uninstalled last WeMod Beta version and installed last stable version. Cheats are now working again.

The unlimited battery is not working, is there special instructions? always running out.

1 Like