Civilization V Cheats and Trainer for Steam

Civilization V
This is the official discussion topic of the Civilization V Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. +1K Money
2. +100 Policy Points
3. +100 Golden Age Points
4. +100 Faith
5. Unlimited Movement
6. Unlimited Fights
7. Rapid research
8. Speed Up Building Creation


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/16/2017
    Started development

  • 03/16/2017
    Released trainer with 8 cheats

  • 04/11/2017
    Bug fixes and game compatibility improvements

  • 04/20/2017
    Bug fixes and game compatibility improvements

  • 05/04/2017
    Bug fixes and game compatibility improvements

  • 06/01/2017
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

3 Likes

I’m pretty sure this is the only trainer to work with all DLC in one tool!

1 Like

cool maybe do CIv BE also

I didn’t even know that existed. Do people play it? I know V is extremely popular.

yea http://store.steampowered.com/app/65980/

Was going to say that game myself, ive been playing it a bit lately.
But i dont know if it get that popular as Civ V and having the same success and all.
After the new DLC more people are beginning to like it because of how much they changed.

yea i like it but i played it alot when it first came out but it hasnt been around as long as civ V so it might get as popular in time

Yes, of course. Civ V wasnt that well taken of the audience before all the DLCs came to be.

I have a problem with this trainer , he don’t launch Civilization and say to me " is too long " , how i can use this trainer ?

Start the game first then alt+tab to infinity and hit start trainer

1 Like

thanks !!!

im still having issues using the trainer i start the game alt tab out to the trainer says its taking to long to start up

The following tools doesn’t works, please update :slight_smile: :

  • +100 Policy Points

  • +100 Golden Age Points

  • +100 Faith

Thanks!

  1. game version?
  2. did you read important notes?

@Symantic

This worked last i tried. Dont think there have been any updates since last time.

2 Likes

Can’t get it to work myself. Have both god’s and kings and Brave New World, when I go to start the game from the trainer it says it takes too long. If I try to start the game and begin playing then start the trainer it will still give me the same error. Can’t seem to figure out a work around. I’m using the steam version of the game.

Can anyone give me some advice? This is the only game I have this problem with.

@VoodooFarm

Common Errors
Game could not be started or it is taking too long to load

Image
Fix:

  • Run infinity as admin
    OR
  • Architecture Mismatch - Either the game is 32-bit and Infinity requires it to be 64-bit or game is 64-bit and infinity is looking for 32-bit.
    OR
  • Your game exe is different than the one trainer is looking for. Post in the thread your game exe name.

This is my issue. But unfortunately I’ve tried these. I’ve run infinity as Admin, both are 32bit, and infinity finds the right exe and it starts the game. But when the game starts for a second or two it’ll say “stopped responding” then infinity throws out the taking too long error. The game still loads after that though. I try to open up the trainer once the game is running but it still says its taking too long, even if I’m mid game.

I don’t have this problem with any other game or trainer though, only civilization. I’ve tried disabling the DLC too, but no luck.

What is the game source (Steam/Origin/Cracked(CODEX/3DM/RELOADED)/Retail/GOG Galaxy)

Steam
Game version - You can find the game version either at game menu or right clicking on game exe and going to its Properties then Details tab. If you can’t find the version, mention if you have latest of steam/origin version or where you downloaded the cracked version from.
Latest steam version
Which cheat is causing the issue for you? Do NOT activate all of them at once instead test each one separately and figure out which one is the one not working for you and let me know.
The trainer itself won’t work
If you are running the game on Hard difficulty or not playing the campaign mode, mention this. If you’re playing normally then ignore this point.
Doesn’t apply
Is the game running in 32-bit or 64-bit for you? You can find out by opening task manager and then checking if it says 32-bit or not.
32-bit install

@VoodooFarm this trainer was made for the steam’s version of the game

In the above questions I answered I stated I had the steam version