Disgaea 2 issues

I have already had multiple issues with the Infinity trainer. However, after finally figuring out how to point Infinity to my game’s location in the Steam folder, I followed the steps I have seen in other threads.

First I launched the game via Steam.
Next I clicked “Start Game” within Infinity.

However, this is as far as I’ve managed to get. My game freezes, and Infinity just has a loading icon next to where the Start Game button was.

I’ve already tried running everything as Admin, and I have done a clean download at least three times. What am I doing wrong?

I guess im a lucky bastard, never had problems with infinity, maybe Disgaea 2 has been updated in the last few days? try disabling momentary your AV, doubt is causing the problem thou.

Oh, that’s the other thing I forgot to mention. I always either make an exception in my anti-virus, or turn it off when using a a trainer like this. So I know for a fact that isn’t causing the issue.

Is this little circle animated in your case?
If its animated you should try letting it circle around for around 3 minutes, i had a similar situation the first time i tested infinity in Fallout Shelter, but left it there for less than 5 minutes and worked.

I´m checkmated by your issue, hopefully a big fish drops by and gives a hand :stuck_out_tongue:

Yes, the loading circle is actually spinning. I waited around 10+ minutes, but nothing ever happened.

Do the game stop responding directly after starting the trainer or after you have activated a cheat?

It stops responding immediately after clicking the “Start Game” button inside Infinity.

I think you already did, but dang it, maybe if you delete cache using this tool?

- ICDV2.bat -

**->**or manually deleting follow this steps

I used that tool when I was having issues getting Infinity to launch at the start. That’s how I was able to make it as far as I have already.

I remember a dev saying that a game shouldn’t crash as long as you don’t activate any cheats.

This seems like a unique issue.

@frank might be able to figure out why this is happening.

Run the game yourself then attach infinity.

When you see that loading icon means the trainer hasn’t yet injected.

That’s what I did, though… I even waited for over 10 minutes and nothing ever happened. The icon just kept spinning.

I thought the issue was game crashing.

What infinity does is download the trainer when that spinning icon shows, if it takes forever there could be several issues such as an AV interfering (depending on your AV, simply adding to exception isn’t enough e.g for avast and norton), the cache folder has permissions messed up (infinity can’t read/write), or corrupted trainer download and infinity tries to communicate with a non-existent/corrupted trainer.

Press ctrl+shift+d then console tab and see what is going wrong.

Well I have completely uninstalled my anti-virus and tested it that way, but the problem still persists. What exactly am I supposed to look for in the Developer Tools menu?

nvm, i just talked to frank…there was a bug. Clear your cache again (icdv2) then launch infinity. It should find your game automatically this time without manually selecting the folder.

I don’t know what I’m doing incorrect, but that still didn’t help. Here are the most recent steps I took:

  1. Closed out of the game and Infinity
  2. Ran ICDV2
  3. Started the game through Steam
  4. Ran Infinity
  5. Infinity did not automatically detect my game.
  6. Manually pointed Infinity to the game
  7. Clicked “Start Game” in Infinity
  8. Clicked “yes” on the notification that comes up asking if I wanted to allow Infinity to make changes on my computer
  9. Game goes into “not responding” mode, and Infinity continues to attempt to download the trainer.

Hopefully that’s enough information to find a potential solution…

1 Like

Hey, i know it is frustrating but can you post your console log? That speaks our language :smiley:

Make sure to select console tab, you can type trainer in filter to only show messages related to trainers injection.

I really appreciate your assistance, and I’m not frustrated with you. I’m more frustrated at myself for not being able to figure something like this out. Normally I can. Anyway, here is the console log.

Also, I’m not sure which version the trainer is, but I checked and found that the game is currently on version

1 Like

Well, we now know what the problem is…thanks for that image.

Steam seems to be running in admin mode whereas infinity isn’t. Infinity tries to elevate itself but fails for some reason. You can try

Run infinity as admin or
Run both steam and infinity in normal mode (non admin).
Run infinity as admin and steam in normal mode

I would say the likely culprit for this issue is AVs but you said you uninstalled it so i am not sure why infinity can’t grant permissions or even need elevation.

PS: Does this happen for other games too or just disgaea 2?

I tried relaunching Infinity as admin, but that resulted in the same issue.
Next I closed out of everything, and launched both Steam and Infinity in normal mode. That resulted in the same issue.
Finally, I relaunched Infinity as admin, with Steam in normal mode, and that still resulted in the same issue. I checked the console log each time as well, and noticed that it was still displaying the exact same messages as before. So I’m really not sure what’s going on. I don’t have any antivirus currently on my computer since I have been trying to troubleshoot this.

I’m also not sure if this happens with any other games. I downloaded Infinity just today for the sole purpose of using it with Disgaea 2. So I don’t know how it behaves with other games.