Elder Scrolls Online Force Terminating with Wemod Error when I don't use Wemod

Let’s start with the obvious. I am not a moron. Not a complete one at least. I know not to try and use wemod with MMOs or any online game.

I don’t even have Wemod up and running when I play those games.

But every time I launch Elder Scrolls Online(as of this morning, 3/11/24)
I get a crash to desktop with the following error message…
Probited: Wemod Overlay.exe (insert extremely long letter/number sequence here) Application Terminated

Short of uninstalling wemod what do I do here?

Try closing the wemod and make sure there are no WeMod processes open in the background.

No luck. I even used Task manager to completely close the App out.

There’s two background processes for wemod in the Task manager that I can’t close. There was three background processes originally. One did close. And the App of course was closed from the both in the app itself and from the task manager.

I either crash to desktop within a minute or two of launching the game or the game won’t launch at all, and everytime it’s the wemod overlay error.

I don’t even use the wemod overlay. Most of the time I forget it exists and just minimize whatever game i’m using wemod with to access the app directly like I always have, or use the hotkey shortcuts

You can uninstall the overlay if you don’t use it.

Hello.

Having the same issue here. ESO terminates with “invalid WeMod overlay.exe”.

How do you turn off the overlay? I’ve looked in the game bar, but it is not intuitively obvious.

Thanks.

I’m also unclear how to uninstall just the overlay

Open the gamebar then click the widget menu, go to the store, then uninstall it from the installed widgets. I closed it from CMD and I’m not having any issues with ESO

Remember when I stipulated that i’m not a “complete” moron?

Where’s the widget menu?

Left most option in the gamebar header menu.

So when I use Wemod i’m using the entire App. If there’s a bar-only version I didn’t know of it.

On the App my top options are Home, My games, Explore, Creator.

To the right of those options there is a sort of mini-bar with my name as the left most option. To the right of those are some additional buttons. The Left-most one says “Click to use wemod remote” when I mouse of it. Directly to the right of that is “Click to use wemod overlay” but like I said I never use overlay anyway. Not intentionally at least. And really all that happens when I click on that is a little dropdown telling me to use Win+g to access the overlay ingame.

Nothing in here seems to be giving me options that look like what you are describing.

Just a heads up if the system/servers detect it you could face a temp or perma ban. Always try to remember to close Wemod out completely in everyway possible before playing MMO’s or just anything online unless you wanna play with the chance to get banned on the game or your account banned. I could be wrong but hey is it worth the risk?

I finally decided to pop into my windows “Add/Remove programs” function and found the overlay in there. Uninstalled it and that did the trick for me.

1 Like

I’m very glad you posted this! I was having the same issue.

Did anything happen to you @TheRedFear ?
I had the same issue today so deinstalled Wemod cause im scared to receive a permaban for literally nothing i did.

THIS is the only way to disable it