Error code 9

Basically whenever I launch dishonored 2 This comes up after I click yes to allowing steam and infinity to run. I’m on windows 10 if that helps. I’m not sure if this is just a bug with the current version or if there is a fix that i need to do.

Do you get this ERROR code, only while launching/playing Dishonored 2, or all other games as well ?

Is any kind of intrusive firewall active on your system, including the modem/router settings ?

Check for any anti-virus/AV software as well, including “Windows defender”, though I doubt these might be directly causing Error code 9 with this app.

Make sure you are not behind any kind of proxy/VPN. Are you on a PC or a LAPTOP/mobile ?

What’s the exact build, version number of your Windows 10 OS ? Is the OS fully updated ? Try to restart the INFINITY tool, as well as your OS.

What happens, if you manually direct INFINITY to the Game’s installed path and location ? Does the app properly detect the game, which is Dishonored 2 ?

If you click on the FIND GAME button, you can also manually select the game’s folder. This should automatically open the PICK FOLDER pop-up box and window.

But try to attach INFINITY, after you have started the game, once a Mission level has been loaded. You can also start the game via Infinity, but try the other way around.

You can try to re-install INFINITY from scratch. But before doing this, kindly remove and delete ALL previous traces of the installed Infinity app on your system (use any REGISTRY cleaner/repair tool, if need be).

Go to the following location and path, and manually delete both the “Daring Development” and “Infinity” folders, if they are still there.

C:\Users\Your- Windows USERNAME\AppData\local\Daring Development, as well as C:\Users\Your- Windows USERNAME\AppData\local\Infinity.

Look for the ROAMING folder as well, under AppData. Some folders can found under “Roaming” as well.

Check this installed path as well, i.e. C:\Users\Your UserName\AppData\Local\Package cache{some random numbers} folder, to remove any previous traces of Infinity.

Try to re-download/update INFINITY from this link:

I’m going to answer your questions in order. My windows 10 is fully updated. The error happens shortly after i launch dishonored 2. Theres no kind of firewall system besides the windows one and I’ve tried disabling it already. I’m on a PC. I’m fairly certain I’m not on a proxy / vpn. Infinity only gives me options to use it with games i have currently installed, one of which being dishonored 2. I can try the find game thing, but i only see the “search for a game” in the top right, not a find game button. I’ll try starting infinity after i launch, and deleting those files before i reinstall. I’ve already tried reinstalling once. I also forgot to mention that i used to not get the error with dishonored 2, but then it just started happening. Also thanks for taking the time for trying to help me, I appreciate it :slight_smile:

i think you forgot to answer the most important question. Do other games work with infinity?

God I must be thick if i didn’t answer that. Yeah, to my knowledge all my other games work with infinity

Hey thanks Nick, deleting the folders and reinstalling worked. As i said earlier I’m greateful for your help



I know what the issue is, and it’ll be resolved soon! For now, deleting the trainers folder in Roaming will do the trick.

plz where do i delete the trainer folders

btw i am using the fallout shelter trainer

Read this: - ICDV2.bat -

Delete the file[s] manually or run the program I made that deletes the cache and launches Infinity (click the blue text at the top to download it).

1 Like