EVERSPACE Cheats and Trainer for Steam

This is the official discussion topic of the EVERSPACE Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Shield
2. Unlimited Health
3. Unlimited Fuel
4. Unlimited Items
5. Quick Cash
6. Unlimited Energy
7. Unlimited Rockets


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 01/17/2018
    Started development

  • 01/17/2018
    Released trainer with 8 cheats

  • 08/26/2019
    Bug fixes and game compatibility improvements

  • 07/27/2021
    Unlimited Shield cheat added
    Unlimited Items cheat added
    Quick Cash cheat added
    Unlimited Rockets cheat added

Like what you see?

Check out all of the games WeMod supports here.

thought this was for the windows version… :frowning:

It never is when there is a steam version available.

Hell YES! Let The Grindage Begin!

1 Like

PLEASE update it for Windows version.

It isn’t a simple matter of updating for windows store version but rather making trainer from scratch usually. I’ll see how different winstore version is for this game and push a trainer if it doesn’t require making a completely new trainer.

@C_Maggotbone I just released the windows store version :slight_smile:

1 Like

For some reason infinity wont launch the game and load the cheats. Keeps telling me that it failed to load cheats but it doesn’t even try to load the game. its also only affecting this game.

Are you using this for steam version?

Or try loading the game first and than infinity.

Restarting my pc twice seemed to fix it. for now.

It seems that cheats do not work on hardcore runs as my game crashes within 2 minutes of activating and shields and health go down regardless if the cheats are active.

Is hardcore different than normal game ?

It ended up being my GPU couldn’t handle the instant death amount of damage from the colonial warship energy cannons while I was invulnerable… RIP epic graphic settings

I’m having an issue with getting the cheats to work. Everything was working fine a few days ago, but today none of the Everspace cheats are working. I’ve tried it on “Normal” and “Hard” difficulty (not Hardcore). There’s the check-mark next to the “play” when the game is running. I have tried launching the game from Steam and then loading Infinity, I have tried launching the game from Infinity itself. I can toggle the cheats on and off, but they don’t actually do anything. On “Hard” difficulty, the cheats for Unlimited health and Unlimited energy refuse to remain toggled on. (I turn them on and they immediately turn off)
I’m running windows 7, Steam version, legit game (not cracked). I have tried re-installing and rebooting both Everspace and Infinity.
Possible causes: on the 9th, Everspace updated to version 1.2.3, so that could have broken it, or it could be Infinity’s new update?

Probably. But does it work in normal mode?

I’m having a similar issue as Asdy, I can get the credits, fuel, missiles, and cool down to work but, I can not get Unlimited Energy or Unlimited Health to stay on. Same as Asdy, immediate turn off once activated.

They do not work in normal mode. A few cheats say they are on (such as the missiles) but they aren’t actually working. Zombicide-II, when you toggle the missiles cheat, does it work? My cheat with toggle “on” and remain on, but I have a limited amount of missiles.

No my missiles were unlimited, no matter what gun was equipped as secondary.

I played a zone for a while on Normal Difficulty, and then had to pause it for a while (about 20-30 minutes) when I came back, the cheats that were staying toggled “on” (but were previously not working despite being “on”) were in fact working. I had Unlimited Fuel and Unlimited Missiles. So, it’s possible I need to toggle those cheats on, go make myself a drink and a snack, and then come back to enjoy the space-mayhem.
I still cannot get Unlimited Energy and Unlimited Health to work, but I’ll keep testing and if I do manage to get them to activate, I’ll report back.