Evil West Cheats and Trainer for Xbox

Evil West
This is the official discussion topic of the Evil West Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Infinite Health
2. Infinite Energy
3. Set Gold Multiplier
4. Add Bucks
5. Set Extra Perk Points
6. Set Knowledge Multiplier
7. Set Current Level
8. Add Experience
9. Infinite Ammo
10. Massive Damage
11. Instant Acceleration
12. Set Movement Speed Multiplier


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/25/2024
    Started development

  • 03/25/2024
    Released trainer with 12 cheats



Like what you see?

Check out all of the games WeMod supports here.

2 Likes

The Evil West cheats have been updated!

Changes:

  • Released trainer with 12 cheats
1 Like

needs updating… perk points, level and xp not working

2 Likes

Hi! There has been an update to the trainer. Make sure to use the most recent version, which you can check by going to the history page. You can try restarting the WeMod app as well.

1 Like

all of the mods are not working at all
health i think

1 Like

when you get to the first boss before that mods break the game after you kill the enemies it wont let you get to the first boss at all

Mod not working for me either sorry. The gold multiplier did but not health or energy (xbox version).

1 Like

comfirmed xp dont work no perks work and xp to lvl up dont work all others work fine and some of the missions glitch on you when you have mods on needs a nother good update

I can confirm the ones i have tried below work for me

Inf Health
Inf Energy
Add Bucks
Add Exp
Massive Damage
Infinite Ammo

The Perks one doesn’t work for me at all and i have tried things like pressing the button a few times before leveling to see if the value changes. i have tried pressing the button a few times before using a perk point to see if the value changes. I have tried pressing the button and opening/closing/reopening the menu and still doesn’t change. its shows on the trainer the value has change just not in game

I have not tried any of the other options as dont use them.

its a great trainer just shame about the Perks options