FINAL FANTASY VIII Cheats and Trainer for Steam

This is the official discussion topic of the FINAL FANTASY VIII Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Items
3. Add 5K Gold
4. Instant Recharge
5. Save Anywhere


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 04/24/2018
    Started development

  • 04/24/2018
    Released trainer with 5 cheats

Like what you see?

Check out all of the games WeMod supports here.

1 Like

It doesnt recognize the game in the steam folder. I also tried doing it manual but it doesnt work neither.

1 Like

Would it be a possibility to have something that would allow you to always win the card game? You guys have something like that for the Witcher 3 and it would be a nice little thing to have, if it is possible. This would kind of speed up getting ultimate weapons is the disc one portions of the game. If it can’t be done no big deal, I love what you guys do and keep it up.

The software does not take into account the game’s launcher. Could you do something please.

Launch the game then alt-tab and start Infinity.

Thanks for the answer but did not work.

Ya my trainer wont allow, 5k gil , unlimited items or instant recharge. it turns them off as soon as i turn them on… 5k gil makes a ping sound like its working but no gil is added. any help would be nice.

1 Like

i try it on steam but it’s currently not working, if you need something let me know

great game on PSX beat this alot(not as many times as FFVII)

The Save anywhere feature does not work. But that is inconsequential to me. I would really love there to be an option to acquire all magic, all GF’s, and all items. also all weapon upgrade magazines for every character. Then you don’t have to farm the tough magics in island closest to heaven and hell… stuff that makes the game take 80 hours. thanks @STiNGERR

1 Like

The save anywhere pointers may be too dynamic to work each time unless the cheat is initialized early. When that happens in other games it sometimes helps to initiate it very soon after a restart of the game. As soon as you load a save, do a “save anywhere” save. That will initiate and trap that pointer at that memory location for the entire session so save anywhere should work until you close the game.

@STiNGERR This is perfect! Thank you for this trainer!

Took a bit to figure out why the save anywhere did not always work. OFC once I did it seemed obvious and I blame lack of sleep …

Other FFVIII players having issue with the save anywhere; The toggle tells the game “This space I am standing on is a save spot” so if you move even a little you just need to toggle off and back on again, do not move and save. Works EVERY time, at least the last hundred I used it.

EDIT: For some reason this did not post into the FFVIII trainer page. Can someone move it please? Sorry!

Were you ever able to find a fix for this?

I can’t find the game automatically and if I do it manually it asks me if I have problems finding the game and that I can start wemod with the game already started, the problem is that it doesn’t work anyway, both the extra 5k of money, and life unlimited. I have not tried for the others who are present because they interest me relatively. can something be done? the version of the game is the latest released so it’s not a version problem

The trainer was working for a couple hours. But now, whenever I activate they either do not work or turn off. It may need an update.

1 Like

Trainer still doesn’t work. Please update.

the cheats dont work for me please update thank you

Is there a fix for this yet? I upgraded to Pro for nothing semms like?

Hello, in my case the game is not recognized in the library, so I have to include it manually and the unlimited items trick doesn’t work (it activates and deactivates instantly). Please fix it @STiNGERR :frowning_face:

1 Like

some code need updates some turn off slowly