App Horizon

Format Xbox 360 USB key back to normal fat32


#1

Hello.

I have this strange issue with a USB key. I formatted it in xbox in order to inject a file using Horizon, which I successfully did. Then I wanted to format the USB back to normal fat32 in order to copy an ISO game from my PC to Xbox. I formatted the USB with the standard windows formatting tool. I extracted the ISO to my fat32 USB and opened the USB with FSD file manager in xbox. I’ve done this before many times, but this time the USB was empty. Then, when I put it back in PC the folder structure is changed. It has a folder with squares in the name and a few more files, and the key is inaccessible *whatever I click a window shows up saying I cannot access files or folders). This doesn’t happen with other USBs that were never formatted for xbox. It seems like xbox remembers that THAT particular USB is an xbox usb, no matter if I format it back to fat32. I also tried low level formatting but nothing seems to help. Any help is appreciated.

Thanks!

EDIT: It turned out that just that particular USB drive has problems. Not sure why, though.


#2

Glad you seemed to have solved it!

Closed!


#3