Games not launching/endless loading

Apologies if a similar issue has been solved before - I tried a search and didn’t find anything quite the same.

I newly installed WeMod just a couple of days ago, and have not been able to get it to launch any games. When I click “play”, it says “loading” like it’s supposed to, but stays like that endlessly and nothing else happens. I have added the appropriate exceptions to my antivirus, and also tried completely disabling it with no luck. It might be worth mentioning that upon my first install and the couple of reinstalls I attempted afterwards, I got an install error and was prompted to do the offline install. Not sure if that is related at all, but I guess I found it strange that it happened each time.

If it matters, I’ve mostly been testing with Cyberpunk 2077 on GOG, but have also tested a couple of Steam games with the same result. I also tried opening the game on its own, switching back to WeMod and activating it that way, but had no luck.

Thanks in advance for any suggestions!

Welcome to the community. Great having you here. :slight_smile:

Sorry to hear of this issue you’re having. It does sound like a classic case of a security program, like an antivirus on a PC or firewall on a network, blocking the trainer from either downloading or injecting. Some troubleshooting is below:

  1. Are you using your own internet? Or internet which belongs to an educational institute like a college or university?
    If it’s the latter, you’ll need to use a VPN so that the trainer can download, because the school will have an additional security program on the network that you have no control over. Windscribe is one VPN that I’ve seen recommended, which has free options.

  2. Are you certain WeMod is added as an exception in your antivirus? Double check from this thread: “Wemod failed loading the cheats into your game” / “We’re having trouble downloading the cheats” - WeMod Support.

  3. Open your antivirus and go to the quarantine menu (also called the virus chest in some programs). Have a look for any WeMod files in there which may have been quarantined despite you adding it as an exception. If there are any, whitelist and de-quarantine it from here.

  4. Try updating or repairing .NET Framework. I’d recommend updsting to version 4.8 if you haven’t already. Here’s the official link to Microsoft’s .NET Framework download website: Download .NET Framework 4.8 | Free official downloads.

Still an issue? Aside from Cyberpunk 2077, what other titles are you trying? And are they all legitimately purchased or have you been naughty and pirated them?

Keep us updated. :slight_smile:

Thank you so much!

I’m on a university network, which I haven’t had much trouble with before so it never even crossed my mind as a potential issue! A VPN did the trick, and now it’s working perfectly. Thank you for the very quick and helpful response. :slight_smile:

1 Like

Thank you for the update.

Glad to hear that this was able to be resolved and that you can now use WeMod with your games.

Enjoy using WeMod and always feel free to pop into the forum if you have questions, need support or just to grab free games from the deals & giveaways section. :slight_smile:

This topic was automatically closed 6 hours after the last reply. New replies are no longer allowed.