Having Trouble Downloading Cheats issue

After updating to the latest version, i am unable to utilize any cheats for a couple of days. Upon pressing play, the “were having trouble downloading the cheats” prompt appears.
i have tried,

  1. Uninstalling, clearing the cache, turning off any firewall and reinstalling (from the latest version on the website and a link by Frank in a similar thread)
  2. Restarting my computer a few times
  3. No, i do not have BitDefender
  4. Switching to beta version
  5. Downloading the trainers by itself also results in the “failed to download :(”

Please help me out! Any suggestions would be appreciated :slight_smile:

Hello there!

Some questions:

1 Like

Im having this issue with multiple games (AC Odyssey & L4D2 from steam and Borderlands 3 from Epic)
Yes, ive killed and restarted WeMod.
Yes, i tried turning off both,
Ive tried using my own connection and university’s
My OS is 18362.720
yup they are both up to date. Please help :frowning:

Try using a VPN like Windscribe. Here’s the direct download link: https://windscribe.com/install/desktop/windows. You get 10GB free every month and they have an annual plan for like 50 USD.

1 Like