Help RAGE update could not be found Error!

OK so when i go on RAGE and it asks me to change disks i change them but it starts to load a little and then it goes to dash and it says “This game requires an update, but the update could not be found.” and i looked on and still no help and i called bethesda and still no help! can someone help me! :’(

I’m encountering the same issue, but just starting the game again and continuing campaign works for me

edit: start the game from the disc you are going to. like I put in disc 2 cause i’m going to subway town

I got the same error, i just exited the game, ejected disc 1, loaded disc 2, play and all was good

but when you do that you have to load the save and to do that you need to load disk one and then disk two right?

Not if you load the auto-save. It makes one right before asking you to change disks.

Are you guys running ISO RAGE?

Ya but still, why does it do it in the first place? Like, where is this update? You can not look for updates for games like you can on the PS3 and system updates. I know it just automatically finds updates when needed but you know I wish there was a button to check for updates. Is there anyway to fix this update not found problem? I know you can just go to dashboard and start it from there but you should not have to, to begin with. Bollocks. lol

I bought the game from GameStop and have the same issue. After messing with it I found out TU1 is what caused this.

If you have the game installed to the hard drive with TU1 on your hard drive then you will get this error when switching discs.

This is ******ed as this shouldn’t have gone out like this because it should have been tested. It seems like no one even made the effort to test this update.

You will have to wait for TU2 which is going to be a while.

Go to Memory > Hard Drive > Rage and delete Title Update #1 and play offline if it bothers you that much or just delete the discs from your hard drive but then the textures aren’t as good of quality.

ihave a similar problem my minecraft used to work perfectly but now when i put it in it says update can not be found I need help

You should make a new topic about the problem and tell us the details, this topic is 4 year old.

@Chris guess this should be closed.