Horizon Crashes at Startup

I know a lot of people has encountered this problem and I was among them.

So I don’t exactly know what happened, this problem happened already in a few previous patches. But in the previous version, all I need to do is to reinstall Horizon.

But now, even with the new update, Horizon crashes at Startup. “Horizon.exe has stopped working”, the only message that I received after opening the program. But there’s something weird, it appeared in my Task Manager for 5 seconds, occupied 28.5% of my CPU Usage and then terminated itself.

Here are the method I tried: (All of them didn’t work)

  • Reinstall Horizon (Doesn’t Help at all)

  • Uninstalled .NET Framework 4.6 and installed .NET Framework 3.5
    (No significant sign of help, only extended the time of waiting for the program to open and then crashes)

  • Activated every feature that is relevant to .NET Framework 4.6 and 3.5 in the “Windows Features” Selection.
    (Doesn’t help at all)

  • Oscar’s Fix (The Link is down)

I think I have tried all the Forum Moderators’ solution, but none of them worked however.

And here is my system information: (In case if there’s something that I missed)

Type of O.S. : Windows 10 Pro x64
Version: 10.0 (Build 10240)
Anti-Virus: None (Microsoft Default Protection)

Extra Information:

I visited the Event Viewer and found this Error Report from the Horizon.exe
Here are the details:

Fault bucket 128960186161, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: horizon.exe
P3: 56524abb
P4: Horizon
P6: 56524abb
P7: b65
P8: 0
P9: System.TypeInitialization

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: e3e2ada8-91f2-11e5-9be3-448a5bd41669
Report Status: 4104
Hashed bucket: dbdf4ba5ff763af0939145f16d501834

Hopefully this will get fixed soon because I have a lot of Xbox 360 games save waiting to be edited.

Thanks and have a good day!

Ive encountered a new update for the mod tool and it says setup failed 0x88713ec - asia, wonder if anyone can help with it??

Thanks for the information. I’ll be looking into this.

Can you send me this file if it still exists?
C:\ProgramData\Microsoft\Windows\WER\ReportArchive \AppCrash_horizon.exe_2fb54aae78ffc17585f5703b7212 39189577bb62_00000000_20a50441

Also, try installing this:

Microsoft Visual C++ 2005 Redistributable Package (x86):

Sure, I have attached the file link below (MediaFire):

And thanks for the advice, I will try it. :smile:

Sorry, but it seems that installing the C++ Package doesn’t help.

I have the following versions of Microsoft Visual C++ though:

2005 Redistributable
2008 Redistributable x86
2010 Redistributable x64
2010 Redistributable x86
2012 Redistributable x64
2012 Redistributable x86
2013 Redistributable x64
2013 Redistributable x86

Still, good luck on finding the solution! :smiley: