Horizon "Invalid STFS Package" and "Cyclic Redundancy Check" Error?

As the title suggests, I am facing these problems .
What can be the possible cause ?

What are you trying to modify?

Thank you for replying , I am actually trying to inject some save games into my profile , I have tried quick fix and replacing method .
But I’ve noticed an interesting thing too , that when I try to inject the save game , it asks me to choose profile , If I skip this step , it suddenly adds the save game but the profile is set to ‘unknown’ and when I try to change it into my profile , damn , the Cycler Redundancy Check Error pops up.
When I try to add to Title Updates or Themes , they add just fine with no problem .
I think I have explained it well …

Invalid STFS Package means the item is not a valid CON, LIVE, or PIRS file.
a Cyclic Redundancy Check error typically indicates a problem with the storage device.

“Invalid STFS Package means the item is not a valid CON,
LIVE, or PIRS file.” Then ?

How do I solve the problem ?

There is probably something wrong with the game saves you’re trying to inject.

Remod a fresh SAVE and make sure to rehash+resign before injecting.

Make sure the games are of the right file format for the game. Skyrim for example uses two different extensions for PC and Xbox.

Edit: What are you specifically doing? downloading these saves from a site or modding them yourself?

Horizon only let’s you add game saves, DLC, profiles, etc. You can’t just add any file, make sure you are adding a valid content item.

Thank you for your support guys , I have downloaded the game saves provided by Xbox360iSO members , I have downloaded save games for Tekken Tag Tournament 2 , Naruto Ultimate Ninja Storm 3 & WWE’13 .
So far , I could only make Tekken Tag Tournament save game inject properly into my profile and even that was by trying over and over and eventually I got luck and the save game was injected successfully .
The other two are still giving me errors , to make sure that the saves are not corrupted , I made a save from scratch with my Xbox 360 , extracted it into my desktop and then I tried to inject it again after deleting it from my profile , and alas! , I do not know what is going on …

Well , I guess there is no more help or support I am gonna recieve from here …

Sounds like your storage device is going bad. The CRC error is never good and might be affecting newer content you create.

Sorry for not getting back to you! I’ve been quite busy.
I’m glad the first one worked but the other two did not which stinks.

Can you follow up on the saves and make a post if you can in the place you got them to see if they were modified in another editor. If so, you might get an error.

If you can, that would be great!

Once again, apologies! :smile:

Thanks A Lot for Your Replies @Eaton & @Pavman ,

No Problem @Pavman , I’m Glad That You’re Back …

I have solved the problem (for now) but by using Modio not Horizon , when I opened the non-working saves in Modio , it showed me their Profile ID & Device ID which were of the person who uploaded the save , I replaced them with my Profile & Device IDs and then added them again and they added perfectly with no problem at all .

I think there should be an option in Horizon too , so we can change the Device & Profile IDs , because other people’s IDs are definitely not gonna work in our consoles !

You can do this in Horizon.

@Joe_ Ummmm, How ?
I would really like to know because Horizon is much user friendly and easy to use .

Use the “Package Manager”, it’s on the “Tools” tab.

Can’t tell you how, I don’t have windows anymore so I can’t run Horizon.
You’ll have to ask someone else. Sorry.

EDIT: Nvm, You’ve already got a reply.

@2FacedDevil , I’ll try it shortly , thanks for your response !

YES !!


The “Package Manager” in “Tools” Tab Worked & All The Non-Working Saves Are Being Added Without Any Issue .




Everytime mean I try to Inject a new file it says.The source device cannot be the same as you wish to copy the files to please help.