Horizon just shows logo for a few seconds then closes

I was looking at the task manager and Horizon does exactly what I mentioned in the title. I am using Windows 10 64-bit. Is there a solution for this?

Try to run it in another Windows mode or codex.
Even if there may be a firewall to accept apply it.

If you have an antivirus accept it and deccode the file with the archive from your virus scanner then it will work probably.

Most times that’s a net framework issue. Horizon requires 3.5 to run. Go to control panel>programs>programs and features and click on turn Windows features on or off on the left. If it’s turned off turn it on or if you don’t have it install it.

1 Like

I tried running it in Windows 7 mode and have done what SteveWonda (nice username, bro) instructed me to. Is there anything else I can try?

I would say disabling the antivirus to test if it fixes the issue

1 Like

I’m using Windows Defender and have already enabled Horizon in the exceptions.

Like SteveWonda said it might be a Framework issue. If that doesn’t work try disabling your anti-virus. If that works then the exception you attempted to make in the AV didn’t really work, and it’s the AV. If you disable the AV and it works, then look further into why it’s not working even with the exception.

1 Like

Tried disabling Windows Defender and it didn’t work. Is there a way to repair NET Framework?

There is a way to repair the https://www.microsoft.com/nl-nl/search/result.aspx?q=framework&form=MSHOME
If you need anything more just ask.

Probably that is gonna fix your issue.
Otherwise try to update even every other driver fom the standing card in your operating system.

It should be easy to google.

Just FYI, Horizon requires net framework 3.5. Any newer versions (4, 4.5, etc) are not required, nor do they include v 3.5.

1 Like


Have you first tried to remove, and uninstall the previous version of the Horizon App which has been installed on your OS as well ?

Kindly try to re-download and install HORIZON from scratch. Make sure to run HORIZON as an ADMIN/Administrator.

It might be possible that there are still some missing/corrupt registry entries on your system, though I’m not jumping to any conclusion, as of now.

But, use a REGISTRY cleaner tool to fix any errors, if need be.

Are you on a Virtual machine/BOX, or the like, or you are using a shared system folder ?

Just asking, because make sure you have full Administrative rights to do any ask (Turn off UAC/User Account control).

Give this a read, just for reference:


Only download Horizon from WEMOD’s official webpage, as given below. But before you re-install HORIZON, kindly remove and manually delete all previous versions of the app from your system.

Remove folders under the APPDATA path and directoty. C:\Users\Your- Windows USERNAME\AppData\local\ Daring__Development__Inc


Anyways, if you already have .NET Framework 3.5 properly installed, and configured on your system as well, then the horizon app might be getting blocked by some other software, or in some cases the file could also be corrupt.

Else, there might be some interference with the Horizon tool on your system, which is preventing it from opening.

Open the TASK MANAGER and check what other processes are still running in the background, when you launch HORIZON. Are you using any Wi-fi connection as well ?

Check the modem/router firewall settings, if need be. If you still continue to face this issue, then it could be an OS issue, and/or it could also be related to Cached Installer problem in some cases.

Assumption, might not be fully relevant in your case, but give it a read, if you face any issue while installing and running the horizon app.

If suppose, Windows OS cannot properly load the Setup.msi file, then either the flle is corrupt/missing, and/or is infected with a Virus or malware (in some cases), and can sometimes prevent apps from being loaded.

Corrupt Windows registry keys can also sometimes attribute to this kind of error. If the Windows Installer engine is corrupt, disabled, or installed incorrectly, this may cause any program installation issues.

An MSI is a Windows Installer database.

Windows Installer (which is a service installed with Windows OS), uses this to install software on your system (e.g. copy some files, set registry values, among other things).

The Windows Installer package/file might also be corrupt in some cases.
Make sure .NET Framework is also properly installed, and/or configured on your system as well, and you don’t have any corrupt downloaded “Horizon” file.

Make sure that the Windows Installer service is also not set to Disabled.

This can be checked by typing services.msc in the Search box, or just click Run then type services.msc in the dialog box. The Windows Installer Service might be having a DCOM permission level problem, or a registry.

sorry for typo errors…

1 Like

Unfortunately, I’ve tried all the steps with no success. I’ve even reinstalled Net Framework 3.5. Should I just give up?

Nope, not yet. There has to be something related to your OS, which is causing this behavior. Before quitting, let us try some other workaround, if possible.

Before that, I need to ask something. I presume you are using Windows 10 OS ? Is this is a fresh OS format and install on your drive ?

Did you upgrade to Windows 10 OS, coming from 7/8.1, or you did a CLEAN format and install of the copy ?

What’s the exact BUILD, and version number of your current OS ?

Do ALL other programs/apps. and software work perfectly fine on your system, or this is only related to the HORIZON software in particular ?

I assume your OS is also fully up to date, with all the necessary updates/patches. But, turn OFF Windows 10 OS automatic updates though, just for the time being.

Are you clicking on the shortcut made by the horizon app on your system, or the main .exe file where it has been installed, to launch and open the app ?

1 Like

Hello. My PC has crashed since the time of this thread was written and at the time my mother was a Gigabyte (can’t remember which, though). Since I’ve installed my new Asus Maximus VII Formula motherboard, Horizon was able to start normally. Thank you all very much for all your help. This thread can be closed now.