Horizon Not Opening Error - Fix

I’ve seen a lot of threads regarding this problem so I’m going to try to help.

Step 1: Run the program as administrator.
(Right click Horizon -> Run as administrator)

Step 2: Restart your computer and try re-downloading Horizon through Internet Explorer if you are using a different browser. (see links below)

Step 3: Disable your firewall/security software.
Control Panel -> Security -> Firewall

Step 4: If you have DotNetBar installed, uninstall it and re-open Horizon.
EDIT: If you are using ObjectBar, close it and retry. (Thanks, Dean25800)

Step 5: Download both .NET Framework 3.5 AND 4.0 from the links below.[/size]

[size=20][b]When finished, make sure you restart your computer.

You may have to re-download Horizon.[/b][/size]

Download links

[size=25].NET Framework 4.0

.NET Framework 3.5


I hope this helped everyone! Hopefully this will end the problem once and for all. :thumbsup:

this happened to me, but all i had to do was run as Admin.

yaa, running as admin normally does the trick

When I had this problem, running as administrator wouldn’t work. And judging by all the threads on this forum about this problem, it isn’t helping a lot of people either.

But thanks for the input guys I added it above.

With the edit, good post

I Know Everyone Asks The Same Q All The Time :confused:

Turn off UAC. Sometimes that helps!

It did for me!

Thus, my thread. :laughing:

Like I said, hopefully this will end the problem and hopefully all the daily threads!

Same thing as running as administrator, basically. But thanks!

i did every combination of .net framework versions except 3.5 and 4, and it works, thanks!

You’re very welcome! Glad I could help. :smile:

I restarted my computer, ran as admin and re-downloaded it and still won’t work.

It worked fine before I bought Diamond, and is there any way to uninstall Horizon, then re-install it?

Someone please help!

Download Horizon with any other browser then IE, so FireFox,Chrome and Safari

I tried everything twice… still no progress :anguished:

No cause Horizon don’t have installer…

Did everything you said, buy still doesn’t work

add this
Start-msconfig-tools-disable UAC
restart computer and it should be fine. When finished, re-enable UAC to protect your PC.

If you enable it again, you’re at step one again.

Why would you remove UAC if running as administrator isn’t working…?

Keeps saying (Not Responding) new Horizon download doesn’t work… after I click install nothing happens. I’ve resorted to using your old horizon but now it keeps saying (Not responding) and my mods arent saving