App Horizon

Horizon wont connect to server


#21

It’s doing the same thing for me can anyone help me ? It always says “failed to connect to server” and I disabled firewall and ran as admin can you help me anyone ?


#22

Have you downloaded the newest version? If you are using AVG you need to disable the hot spot shield also.


#23

Please help I want to keep modding


#24

He is trying to help you :rolling_eyes:

Do you really need to be “online”? The free tools are available offline. Do you have a secret diamond account you are hiding from us perhaps? :thinking:


#25

This post was flagged by the community and is temporarily hidden.


#26

Its Almost 2017 And Im Having Problems With The Modding Tool I Did Everything That Was Suggested And Im Still Having Problems. If You Have Any Ideas Please Contact Me By Emailing laceliteanonymous@gmail.com

Thank You For Your Time


#27

I also have the same problem and I did everything they said and it still won’t work


#28

yea im having the problem to and i have my firewall off only one random time it connected maybe has something to do where i was in my house i dont know what my problem is


#29

Ive downloaded and installed it but when i go to open it it says “cant connect to server” i have deleted it 2 times and redownloaded it but it still hasnt worked please could you help me and email me at -remove-
Because i rrally wanna play mooded factions for minecraft xbox one edition


#30

Horizon is not for xbox one. Hope you know that. Other than that I wouldn’t just post the email here.
He will help you over the forums like he does for every other person aswell.

Check your AV though please. It’s probably blocking the connection


#31

I’ve removed your email as we do not reply to users through email.

There isn’t much I can do about Horizon not connecting besides tell you to make sure there aren’t ports blocked and add exceptions for Horizon in your AV and Firewall.


#32

Please can someone help me when I try to open horizon it says cant connect to server ive tried everything that anyone has said it still wont work ive deleted it disabled my anti virus run as admin everything anyone has ever said it did work fine but now it don’t work at all I don’t know why please help


#33

You could try adding a firewall rule and making an exception for horizon (and any horizon-related files) in your anti virus program. These things can be googled if you don’t know how to do them.


#34

like I said ive already done that and nothing works


#35

please help I really need help I cant mod waw without horizon or minecraft


#36

Are you sure you are using the newest version of horizon? If not, uninstall horizon, delete left-over files in appdata, download the installer from wemod.com/horizon, install.


#37

yes I am I downloaded it of the wemod web where it said download now


#38

I am downloading horizon to see if there is something wrong with the server.


#39

ok


#40

There isn’t a problem with the server. It is something on his network blocking the connection and there is nothing we can do about that. This isn’t anything new and is probably the #1 issue we have. The most we can tell you to do is try another computer and make sure your av/firewall isn’t blocking it.