Is it just me? or does the Wemod not work at all

I used the WeMod perfectly fine until yesterday, and today it was just stuck at the loading screen. Tried few things and none of them worked so I uninstalled WeMod, tried installing it again, and voila, installation file’s been downloaded fine, but install itself could not be done because it couldn’t download the data.

Is there something wrong with the server? or it there something wrong with my computer or connection.

Don’t have any advanced security things. I’ve only got my dearest Windows Defender.

Hello there and welcome to the community. :slight_smile:

The fix for the black screen issue is simply to use the end task tool on WeMod via the task manager. You shouldn’t have to re-install. Could’ve used the search button here on the forum to find that solution, but never mind. :laughing:

Your download issue is commonly caused by interference from an antivirus program (Windows Defender is still an antivirus).

First of all, please make sure your Windows Defender signature library is up to date. Even if the Defender software itself is up to date it doesn’t mean the signature library is. Here’s how to do that:

If that doesn’t resolve your issue, give the troubleshooting steps in this post a go: Can’t Install WeMod

well, first thx for replying at all… and it wasn’t black screen. it’s stuck at the wemod start loading screen. and I also did look for all the things in the forum and none of it worked… that’s why I tried reinstalling as a last resort…

any help on that matter by any chance…? I’ve used offline installer to install it but still doesn’t work past wemod loading screen.

Please try the two links given above. They contain additional instructions beyond reinstalling. :slight_smile:

been there. done that. failed sadly… :’(