App Horizon

Jtag/RGH expert needed please help with with xex menu. ( that would be @stevewonda )

Ok so I just got my rgh like 2 weeks ago so I’m still pretty new to this but anyways I tried connecting to the Internet but after activating the xbdm plugin(yes I saved it to the hdd) and rebooting my console was stuck on auroras loading screen which was my default dashboard and I waited to no avail. So I launched my Xbox without any plugins and formatted the hard drive as well as my USB which I had also done 2 days prior and had no problem installing xexmenu. Now after reinstalling xex1.2 menu it shows up as corrupted. I’m using a jasper and I know for a fact that it is either jtag or rgh. I’m just worried that I ruined it and can no longer use it as an rgh. Please can somebody help me? Oh yeah I also forgot to mention that I had it connected with an ethernet cable the whole time. liveblock was enabled but idk if booting without plugins effects the network settings with dash launch.

@SteveWonda. He will know. He like 360 wizard.
I know myself didnt really care for Aurora. I kept using freestyle dash. And used trainers from my old site I was moderator on xyzmods. Of course closed now !

Okay thankyou.

1 Like

He pops on pretty often. He should know.

1 Like

Awesome I really appreciate it.

1 Like

He was just on an hour ago must of just missed this
I do have a little knowledge left with rgh but been a while since I used mine.
Nothing better then an rgh 360. Was the best console ever.
My friend paracrypt made all the trainers for Aurora dash.

1 Like

Oh nice. I tried FSD but it seemed outdated a bit I’m not sure if I had the latest version or not. I didn’t even bother checking so I continued to use aurora.

I’ve wanted an rgh for a long time I fell in love with jtags before I even got one. I just really hope its not screwed up completely. If all else fails I will send my slim to sharkyscustoms to be glitched but the rgh I have is a jasper and I heard they are the most reliable.

@dudepudding & @ptondo I’m not actually a wizard of the 360 haha! But thanks!

To be honest with you I’ve never used Aurora and have never ever tried taking either of my RGHs online. I’ve always simply used them the way I purchased them which is by launching XeX menu through ‘Games’ on the retail dash. I do have Freestyle dash and other cool Jtag/Rgh launchers but always just go with XeX menu because it’s the simplest and easiest way for me.

@dudepudding if you’re completely positive that it is Jtag or RGH modded than I won’t ask the obvious questions. You say you formatted the drives. I’ve never done that myself as my 2 have always worked properly. I think you deleted other necessary files to make it all ‘Work’ if you know what I mean. I’m not sure what but I just did about 2 mins of Googling and as you probably already know this same thing has happened to others. Have you read through other threads at places like se7ensins?

Just for the hell of it try XeX 1.1 and see if there is any difference.

2 Likes

Thankyou for the advice I’ll look into it more and I will try 1.1 as soon as I get home and I will post the results. Wish me luck!

1 Like

Good news! I injected xex 1.2 into demos using horizon and it is now appearing on my Xbox. Idk why drag and drop wasn’t working I had it on read hidden files and everything. Thankyou guys for the support. If I need any offline advice I will be sure to ask you.

1 Like