Mass Effect 2 Cheats and Trainer for Origin

Mass Effect 2
This is the official discussion topic of the Mass Effect 2 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Instant Powers Reload
3. Set Credit
4. Set Medi-Gel
5. Set Element Zero
6. Set Iridium
7. Set Palladium
8. Set Platinium
9. Set Probes
10. Set Fuel
11. Unlimited Ammo


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 07/23/2019
    Started development

  • 07/23/2019
    Released trainer with 7 cheats

  • 10/14/2019
    Instant Powers Reload cheat added
    Set Credit cheat added
    Set Medi-Gel cheat added
    Set Element Zero cheat added
    Set Iridium cheat added
    Set Palladium cheat added
    Set Platinium cheat added
    Set Probes cheat added
    Set Fuel cheat added

Like what you see?

Check out all of the games WeMod supports here.

The Mass Effect 2 cheats have been updated!


  • Released trainer with 11 cheats

Please post in this topic if you run into any issues!

oh my god. THANK YOU for making it possible to mod the god d*mn resource amount.

1 Like

i used this trainer over wemod but the unlimited health cheat don´t work for me
i would be killed by activate this cheat

Every time I try to activate this trainer, it causes my game to stop responding… I dont know if anyone else has had this issue though…

It doesn’t seem that anyone else is having this issue, this trainer was last updated on the 14th of October 2019 so it’s definitely up to date. Please make sure you’re on the latest RETAIL copy of the game and try again. Also you can try starting the game manually and then ALT-Tabbing and selecting play in the WeMod app! :slightly_smiling_face:

I used MrAntiFun mods for Mass Effect 2. I did all the necessary steps.I clicked on play and then it started working. Then I tried to change the amount of precious metals and it didn’t work. What should I do?

1 Like

I have the Digital Deluxe version of the game, made sure it was up-to-date, even used the “Repair” function to make sure it was all as it was supposed to be.

When I try starting the trainer (after starting the game manually), it says, “There was a problem starting the trainer. Your game version may not be compatible. You can also try again at a different point in your game.” I’ve tried more than one point in the game and I’m starting to get really frustrated.

Hi, so far the first few cheats works fine for me, but not the set credits cheat, i tried setting it to an amount and activate it but its not working, not sure if im doing the right way. pls help. thanks

I waited until after firing my gun for the first time like it says in the notes before activating the trainer. From what i have seen the Unlimited Ammo works and the instant powers reload works, i haven’t tried the Unlimited Health yet. I did try the inventory adjustments and none of them work for me, i tried using some to the empty and they still did not work. I went to the stores to try to buy something after trying the credits and it did not work. Is there something else that needs to be done to get these to work?

My suggestion would be for you to use a save game editor called Gibbed if you are not able to get the resources cheats to work. He made special editors for Mass Effect 2 and 3 so you could edit everything from story plot points to resources to your appearance. Then just use this trainer for things like unlimited health. Additionally there are mods out there that enable no mini games and 1 probe planet resource scanning that extracts all resources with a single probe. It makes the game much more enjoyable and less tedious. Look on Nexus Mods for them.

would think this app would work if you payed for it. it dose not work at all for any of my games it says play on my thing but nothing

Well If it dont work for any of your games I would think must be something on your end like maybe your antivirus is interfering with the trainer.

well i disable my antivirus and still not working what is the next step i mean it says its running and nothing

Make sure you have the legit origin store bought game and up to date
Can try and start the game first from origin then when you are in game alt tab out then press play button after game is running

None of the resource sliders work for me but the Health,Reload, and Ammo are fine. Im seeing that seems to be a common problem with this trainer :thinking:

1 Like

Unlimited ammo doesn’t work with heavy weapons.