Mass Effect 2 Cheats and Trainer for Steam

Mass Effect 2
This is the official discussion topic of the Mass Effect 2 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Ammo
3. Instant Powers Reload
4. Set Credit
5. Set Medi-Gel
6. Set Element Zero
7. Set Iridium
8. Set Palladium
9. Set Platinium
10. Set Probes
11. Set Fuel


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/16/2017
    Started development

  • 03/16/2017
    Released trainer with 7 cheats

  • 07/23/2019
    Bug fixes and game compatibility improvements

  • 09/03/2019
    Instant Powers Reload cheat added
    Set Credit cheat added
    Set Medi-Gel cheat added
    Set Element Zero cheat added
    Set Iridium cheat added
    Set Palladium cheat added
    Set Platinium cheat added
    Set Probes cheat added
    Set Fuel cheat added



Like what you see?

Check out all of the games WeMod supports here.

The Mass Effect 2 cheats have been updated!

Changes:

  • Released trainer with 11 cheats



Please post in this topic if you run into any issues!

I receive an error trying to load the game through wemod error is Application failed to load: 5:0000065434 Is there a work around for this?

I’d verify your game file integrity and make sure nothing is missing. You can also try starting the game manually and then alt tabbing and selecting play in the WeMod app

im having an issue. the mods say there working no errors or anything but game its not doing anyything at all. like it says set credits to 9900000 whatever but nothing changes in game

Wemod doesnt recognize the process although it starts the game. I run it in admin mode same results. Its bought in origin

There’s your issue. The Origin version of this game won’t work with the Steam trainer. You want to use the Origin trainer by MAF:

image

2 Likes

hadnt notice. Thank you so much

1 Like

Hi THere. I have an issue. In my trainer menu, there isn’t any options to set Palladium or Platinum or Iridum. There’s only the option for unlimited Element 0.

Is this normal or am I doing something wrong?
The trainer itself works fine. Just the options are weirdly missing

I think I can help. on the app there is a tab in the game menu called history. it shows the different versions of the trainer. Click the newest one and the hidden options should pop up. I had this issue too hope this helps!

1 Like

This certainly helped a lot! Thank you so much!
(was meant to reply directly to your post so sorry for my first mistake)

Awesome glad I could help you!

1 Like

Unlimited Ammo option causes the game to crash. Tried without any other option active then when activating Unlimited Ammo at a certain point (Freedom Progress) it crashes.

Not sure why but is there a way to fix this? I am gonna assume there’s no way to fix it and we just have to watch when and where we activate it.

Also, would it be possible to have unlimited talent points like in ME 1?

Cheers.

1 Like

resource options don’t seem to work any more. they did initially but I think that was before getting to the Normandy. since then only the first 3 options now work

Any chance of getting an update? I’m playing through again before the remastered version comes.

1 Like

wemod triner for the mass effect 2 in which onlky first three cheats or the toggles work rest like credits and anything eles doest work at all need help to fix it

hi everyone I apologize if I disturb you I have a problem with vemod it doesn’t work for me I tried everything but nothing, when I activate it I click on play nothing is going to load for a while, We’re having trouble starting or finding your opened game. What does this mean? could you help me thanks

I apologize if I allow myself this message is addressed to Mr. MrAntiFun being that he is a righteous person I want to point out to him that they sell his trainers check the link; mass effect trainer - sisale.shoppingonline2021.com