Mass Effect Legendary Edition (ME3) Cheats and Trainer for Steam

Mass Effect Legendary Edition
This is the official discussion topic of the Mass Effect Legendary Edition Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Ammo
3. No Reload
4. No Recoil
5. Better Accuracy
6. No Skill Cooldown
7. Unlimited Talent Points
8. Set First Aid
9. Set Credit

Important Notes:

Click here to view important information about these cheats.

Launch the game from the launcher before pressing play on the trainer.


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 05/18/2021
    Started development

  • 05/18/2021
    Released trainer with 9 cheats

Like what you see?

Check out all of the games WeMod supports here.

1 Like

Many thanks for creating a cheat for all 3 Mass effect games, this is a massive help.
Top man!

thanks guys for doing this so quick but can we pls get Max Paragon and Renegade cheats and thanks for the hard work


Is there any way to make this work with the Origin version? Or do you know of any work being done on the Origin version?


you bring the file over like the other games where the “fix” button is
find mass effect legendary edition go into your game find me3 click binaries then drag the .exe folder for me3 into the drag and drop area on the we mod menu where you clicked the fix button

in another note does anyone have any idea how to manually change the reputation stats or does anyone know what the reputation is for a ported character ?

Are the skills points resetting after every load screen for anyone else?
I have to redo Shepards skills every time.


yes ive been having the same issue. even turning it off doesnt help.

Same problem as 2 above, besides that doesn’t have any problem.

Thanks for the trainer tho MAF.

Im having the same issue as this.
But I’ve tried this method where I experimented.
Max out all your skills but leave 1 skills that u don’t or wont use empty.
Meaning sacrificing 1 of your skill row to make sure that it doesn’t reset.
I’ve tried it and fortunately my skills haven’t been reset sinced.

This is the example of how I managed to keep my skills from resetting back.
Hope it helps :slight_smile:

1 Like

Edit: solution not work for me.

I havent tried the skillpoint cheat yet so no idea if that one is broken like the ppl above are saying but for me the no skill cool down dose not do anything.


Are referring to my solution?
If so then I’m afraid I don’t know any other solutions.
Perhaps it resets because of a certain skills that cannot be maxed out.
You should try leaving 1 row empty and save and load.
If it resets again then try again for another skill row.
Until it won’t reset again.
This is just my suggestion/opinion.

Yeah, sadly that doesn’t work. Imma just be fine with having point whenever I level up.

Thanks tho!

any plans on releasing reputation mods ?
ive used “the cheaters pad” for the old verion of me3 i was wondering if you guys could take a look at their files somehow and maybe take some of their cheats from there they were able to get all guns and attachments to level 5 also had max renegade and paragon as well as getting all galaxy at war assets but we dont have multiplayer in the legendary edition just yet

thank you for your time
please consider :slight_smile:

On the credits, there is no sanity checking. I am not sure how many bits the UR 3 engine can deal with, or if it is even a problem, just thought I would point it out.

Yup. Also having this bug.

yeah, I found leaving one blank helps make where you don’t need to reskill so often but yeah I wish they fix that.

1 Like

Credits don’t seem to make it into game. Need to use console initcredits (number) for workaround

Yup, same here. Leaving a skill empty does not fix it for me either. I noticed that turning off the cheat and using up all the skill points until you get to the number you started the game with stops the resetting. So i am guessing it does not like you having “more” points than you “should”.