Mod Key Binding 'Clear' Bug

Hey there!

I have run into a bug whilst using Infinity with Zombie Army Trilogy although I don’t think this is a game related bug. Whilst toggling the ‘Float Mode’ on and off, it started acting up and then sticking on. Then it wouldn’t respond to the input key for any of the mods. I tabbed out to see if I could manually turn on/off the mods and I could, but in the process it glitched out a little and edited the key binding for Float Mode. It changed to ‘Clear’ and I couldn’t change it back. Now the mod constantly flicks on and off without me being able to stop it.

I tried changing other key bindings and as soon as I clicked them, they all changed to ‘Clear’ too. So I have about 7 mods for ZAT that are constantly flicking on and off. Quite puzzled!

I was able to quit Infinity and the game fine but the key bindings still say as ‘Clear’.

I’ll be thankful for any help.


Does this happen only, with the Zombie Army Trilogy game trainer, or other titles as well ?

I haven’t encountered such kind of bug, while using Infinity though.

Have you tried doing a CLEAN re-install of the Infinity app ? By pressing the DEL keyboard button, you can reset any particular cheat option to default.

Check NUMPAD as well.

Open INFINITY, and press CTRL+SHIFT+D combination key, and see if there are any Errors or not, when the game has been launched, under the console tab ?

Give this a try.

Remove all the .BIN files located here, e.g., C:\users\Your windows username\AppData\Roaming\Daring development\Infinity\trainers.

Depending on the game, the numbers might change, e.g, 61-1477409811.bin, or 144-1476900945.bin etc etc.

Make a BACKUP first though. After that, restart the Trainer.

Thanks for your response.

This happens on all trainers now. Whichever mod option I click to rebind the key, it automatically changes it to ‘clear’.

Not sure how to do a clean reinstall. I did do a reinstallation.

I checked the Ctrl+Shift+D, under the console tab and there were no errors displayed there.

I tried removing the .BIN files and restarting the application and the trainer. This didn’t work either.

The Clear key seems to be the one in the center of the numpad. I’m not sure why Infinity thinks it’s being constantly pressed. Any ideas? I can filter out the Clear key as I’ve done for other strange keys.

1 Like

I have sorted the issue!

Turning NumLock off and on a few times has seemed to sort it out! I have been able to rebind all of the ‘Clear’ keys back to their originals now.

Thanks for your help on the problem.


Glad to hear you got it working! That’s very strange though. I’ll see if we can prevent that from happening in the future.

Frank, just need some clarification.

Which NUMPAD key are you referring to here, Numpad 5 or some other ? I tried pressing it, but nothing happens ?

Is there a key to CLEAR all the cheat bindings ?

There is no key to clear them all. The delete key will reset one to the default.

The internet told me the 5 key is also the Clear key, but I can’t find any proof of it.

Oh well, okay. That’s fine. I thought there was a CLEAR key as well, apart from the DEL button which I’m aware of.

Got the same problem here, I’ve tried pressing numlock a number of times and still no luck,
There’s also 9 cheats with this game Thehunter cotw and only 3 cheats keep turning of Unlimited Ammo,
Silent and No Reload they always revert back to disable and in the dev console it says:
no_reload set to 1 by client and
no_reload set to 0 by trainer

Means the trainer needs update.

So when will there be an update

Please post in the proper trainer thread: