My Time at Sandrock Cheats and Trainer for Steam

Heard about CE but never dabble in it. I usually rely on Wemod or Nexus mods. Anyways, thanks for your advice. All the best.

1 Like

I loaded the game, got to the main menu, then hit play on WeMod, and it played just fine, better than when I launched it through WeMod actually. Only problem is, after so long, (times vary) is that the game will still “lag out” and crash. This seems to be a game issue, since it did this without using WeMod as well.

Thanks for the trainer and for updating it!

Since I launch it with a launcher I got the 32bit error message too. However as the game was running I was able to just launch the game.exe directly afterwards and this made Wemod register the cheat and it worked fine to use all cheats ingame! Thx FLiNG!

I initially installed WeMod to get a sofa that I wasn’t able to get for real, but then I found out I wasn’t able to spawn items through WeMod (at least I didn’t figure out how). But then I got lured by all the other possibilities I had with WeMod. So I started using it for everything, I used a lot of the “infinity item” so I could have 999 of all my items. But I hadn’t given up on my sofa, so I downloaded DevConsole, so I could use a mod to add the sofa I wanted. But now, all the time I try to add something to my bag, it spawns a lot of different items, and they all spawn with 999. I I tried to delete WeMod and DevConsole, uninstalled the game and installed again, but this bug still there :frowning: Can someone help me?

There was no need to uninstall WeMod to stop using the inf. item cheat. You just turn it off. If, for some reason your game is acting different (it’s because of the mod), then all you had to do was restart the game, and not turn on WeMod.

Also, what couch were you trying for? Was it one you could make, or was it stuck behind those idiotic token vendors? If it was from the vendors that require tokens, use cheat engine to modify your token number, and buy it. If it is from making one, and you just don’t have the items/updated machine for it, then the cheat that #14 I believe, the minimum crafting item one, will allow you to gain everything you need to make it, as long as you have wood.

This process takes a bit of time, but if you use the slow gametime cheat, and just set it to 0.1 (only hit the buttons once), you can have maxed out machines, items, and almost every item needed to create everything before 10 AM in game. I also built myself a three story mansion fully decorated before 12 PM, so it is doable, it just requires patience.

1 Like

+1 Hour would be very useful. Please add this.
Very often I have to wait until a certain time passes.

The other options work for me (more or less).

1 Like

The My Time at Sandrock cheats have been updated!


  • Bug fixes and game compatibility improvements

I just ran into an issue with the Unlimited Health one. It works great when it’s active, however, once you turn it off, the character’s health bar goes to 100 no matter how i try to alter it. I can get the top number to change (x / y), but not the bottom. I have to keep the cheat on now when fighting or I die to just about anything.

Has anyone else run into this? Is there a work around?

Edit: In case someone else runs into it, looks like quitting and restarting without WeMod active worked.

1 Like

Umm…just set the game time, hold (or push) ctrl+keypad - a few times. I can pass a few hours, or half a day in like a minute irl. Then, when you want it back, just hold alt+keypad -.