.NET Framework

i go to install the .NET Framework 4.7 but once i start installation it stops and tells me and error code but when i look up the error code or try to find help on it i cant find anything. I am running windows 10. the error code is 0x800F081E. Ive used infinity before but with this new updated version i cant use it unless the .NET is present is there anyway i can just use an old version of infinity? Do i need to use 4.7 or can i use a later version of the .NET framework?
i am not the best when it comes to this stuff so treat me like i dont know anything about computers bc i dont (but any help is appreciated)

Update windows, you shouldn’t be having this issue on the latest (or close to latest) version of windows. If it still doesn’t work I think microsoft would be better equipped to provide support for windows products than we are.

Try it.

Before I posted I had just updated my windows. I also just looked, apparently I already have the updated .NET Framework. So i went to reinstall Infinity and it failed to install. Once it failed it prompted for me to install the latest version manually but i don’t know how to do so.
It specifically mentioned the framework so i dont think it should be an AV problem?

You should check if 4.7.2 is installed. Instructions:

To find .NET Framework versions by viewing the registry (.NET Framework 4.5 and later)

On the Start menu, choose Run.

In the Open box, enter regedit.exe.

You must have administrative credentials to run regedit.exe.

In the Registry Editor, open the following subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full

Note that the path to the Full subkey includes the subkey Net Framework rather than .NET Framework.

Note

If the Full subkey is not present, then you do not have the .NET Framework 4.5 or later installed.

Check for a DWORD value named Release. The existence of the Release DWORD indicates that the .NET Framework 4.5 or newer has been installed on that computer.

The registry entry for the .NET Framework 4.5.

The value of the Release DWORD indicates which version of the .NET Framework is installed.

Important

The following table lists the keys of released versions of the .NET Framework only. It doesn't list the keys of preview or pre-release versions.
Value of the Release DWORD 	Version
378389 	.NET Framework 4.5
378675 	.NET Framework 4.5.1 installed with Windows 8.1 or Windows Server 2012 R2
378758 	.NET Framework 4.5.1 installed on Windows 8, Windows 7 SP1, or Windows Vista SP2
379893 	.NET Framework 4.5.2
On Windows 10 systems only: 393295

On all other OS versions: 393297 	.NET Framework 4.6
On Windows 10 November Update systems only: 394254

On all other OS versions: 394271 	.NET Framework 4.6.1
On Windows 10 Anniversary Update only: 394802

On all other OS versions: 394806 	.NET Framework 4.6.2
On Windows 10 Creators Update only: 460798

On all other OS versions: 460805 	.NET Framework 4.7
On Windows 10 Fall Creators Update only: 461308

On all other OS versions: 461310 	.NET Framework 4.7.1
On Windows 10 April 2018 Update only: 461808

On all other OS versions: 461814 	.NET Framework 4.7.2

Source: https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

this is exactly what i did

If 4.7.2 is installed then somethings definitly wrong your copy of Infinity. What antivirus do you have? It might be the AV causing the issue since a few of the popular ones don’t like Infinity anymore.

ByteFence. I deleted infinity and tried to reinstall it multiple times now image

Try disabling/uninstalling bytefence. It probably isn’t the AV but you never know. I invited @Frank over, maybe he sees this and has a solution (freedom time though so might be a couple hours)

1 Like

i was able to pull up the log file although i dont know if it will help

Log says you are running 10.014393 which is Version 1607 (Anniversary Update) according to https://en.wikipedia.org/wiki/Windows_10_version_history#Version_1607_(Anniversary_Update)

You need to update your OS.

Bro youre right i legit didnt notice but like i just updated it i guess it didnt install i also just was sent a repair tool for the framework

Update windows

It was said yes.

@Chris this has been solved and can be closed