New WeMod Overlay doesn't work

I installed the recently published WeMod XBox Game Bar overlay.
However, whenever I try to activate a cheat through it, it reports an error “There was a problem with this widget” and a button to restart it.
I try using it with AC Walhalla.

Is there anything I could do? E.g. collecting logs somewhere?

do you have the windows and g key active in setting, mine works fine but i had to enable it, within the settings

I also have this problem, But it was working perfectly when i first installed it. I used it with Resident Evil Village. I had to completely uninstall Wemod program AND the overlay and reinstall both to get it working again. However, When i shut the game down with Wemod still running, Wemod will get corrupted somehow, and the overlay stops working, Whereby the window that open’s up using Win+G is blank and asked you to open WEmod, which it actually is. Any help please?

YEs. Win+G to open the overlay

Ok, This worked,

  1. Go into add/remove programs then terminate and reset xbox game bar.
  2. use Win+G BEFORE play game.
  3. Cheats should be loaded properly now.
1 Like

Worked for me once only. After first successful enabling a cheat, re-opening the Overlay later to disable the cheat again, the result again was the above error.

I would be glad to help devs to investigate this. They should just let me know if I can provide any additional details (like logs)…

Does it crash when you open the overlay or when you change the value of a cheat in the overlay?

Which version of Windows 10 are you using? You can see that in Settings->System->About.

Logging within the overlay is currently not implemented, but I plan on looking into how we can go about it.

A post was split to a new topic: Overlay cheat activation issue

I also have a problem with the Overlay, I can’t use my Keybinds on Hoi4 (Hearts of Iron 4)

Completely separate from the issue reported in this thread, @PlainTurtle42069. That game was updated recently, hence the trainer needs to be updated to be compatible again. Please check the trainer’s official threads before posting, by clicking the Discussion button in the trainer: Hearts of Iron IV Cheats and Trainer for Steam.

Yeah happen to me as well right now every time I play Elden Ring for some reason the overlay borked out.

The first day playing elden ring it work tho.

Other game like Warhammer 3 the overlay work.

edit : I am trying @LoneWolf2572 suggestion and it work i just need to use the overlay before loading or starting the game and it work, i dont need to restart my computer to make it work again.

edit 2 : today the overlay don’t work at all even when I try the fix, I give up on trying to use the overlay for now. If someone from the devs who know to fix it can help me it would be appreciated.

Another note i have tried uninstalling and reinstalling the overlay and it dont work on elden ring and warhammer 3 too now so my overlay is broken af.

in warhammer 3 i try to change to money value and it just crash and ask to restart but it dont do anything.

I am using windows 10 home.

Thank you. That worked perfectly.