App Horizon

Pictures don't show up in the WeMod program

Hello!

I have an issue with the WeMod application with the photos in the app (for PC and not mobile) not showing up at all. Instead, where there’s supposed to be either the banner for a game or a picture of the game showcased is just blank in it’s place. It just makes the app look odd because of it.

For Solutions, I tried uninstalling but that did nothing. I hope I can resolve this issue.

Sincerely, Colby.

Is it only on the dashboard or do you not see any thumbnails in WeMod? I’m going to guess it is a firewall or av blocking the images for some reason.

1 Like

Hello and welcome to the WeMod community! :slight_smile:

That’s a pretty strange issue indeed, not something I’ve experienced myself. Before we get into the troubleshooting steps below, please restart your computer. I know this sounds too simple to be a fix but sometimes it actually works with strange things like that.


If you’re still having the issue after a restart, it’s possible your antivirus program has interfered with (or deleted) something.

  1. Uninstall WeMod using the “Add Or Remove Programs” tool that comes with all Windows PCs.

  2. Turn off your antivirus. Even if it is the default Windows Defender.

  3. Download this installer and reinstall WeMod: https://api.wemod.com/client/download.

  4. Add WeMod as an exception in your antivirus before you launch it.


EDIT - Of course, Chris beats me to the post :laughing:

Hey, thank you both for replying! I didn’t see the emails to these replies until tonight. So sorry about that! :sweat_smile:

Anyways in reply to what Chris said, it is not only the dashboard as you can see in this screenshot below.

I have no clue as to what is causing it but it could possibly be a firewall or my anti-virus (Avast) like what you said. Now in reply to Ravenfyre, Yes it is strange, I never seen this kind of bug happen before with any application. Including Steam, Origin, etc. I tried your solution but it didn’t work for me. I have just thought of going into safe mode with this but I don’t think it’ll work because isn’t WeMod required to be online? I don’t know what else to do. This is definitely strange but I can live with it until this is solved. :slight_smile: