Ranch Sim New Update

Hey there.

I’ve been using WeMod for Ranch Simulator for a while now. With the recent beta release (Sept 21), the mod no longer works.

I turned off the pro subscription for now since it’s not usable but is there a list or spot to sign up or watch for the update?


This has nothing to do with pro, you just can’t use the buttons anymore. Next to the buttons you will find hotkeys, which you have to use. Pro users and normal users have the same cheats.

The hot keys don’t work either. Plus, some of the features are only available to Pro users. It’s why I subscribed in the first place.

My kids are crazy about the piggy’s in the game and I use the mod to give them money and replace all the pigs they keep killing lol

Just tried it again and same results. It says only Pro users can use this mod. I stopped the Pro subscription because the mod doesn’t work with the new beta update.

I’m just looking to find out where/how to watch and see when it gets updated.

Then the trainer must be updated. I would recommend you to post it here once and then you have to wait for the update. But again even without Pro you are able to use the trainer.

Here’s my screen shot. This mod only works for Pro users. And it says so when you hover over the features.


And thanks for the link! I just posted there and I guess I’ll just watch for updates.

Yes, this is the button feature. Next to it on the right side you see this increase field with a hotkey. This hotkey you have to use when you are not a pro user. You are able to use the full trainer but only with these hotkeys.

1 Like

As @Wentoxh pointed out, all mods are free to use via the hotkeys. You can learn more about it here: Using Mods with Hotkeys

The hot keys have never worked. At least in the year I’ve been using this mod with this game. The only way to make it work when I first started using it was with a Pro subscription and the app. With this latest update, nothing works.

The mod was last updated in Mar 22 and there’s been 4 or 5 updates to the game during that time, including the change to UE5.

I can’t say I’m surprised it’s stopped working.

I’ll just keep patiently waiting for an update and hope it starts working again.

There is no difference between the hotkeys and enabling them with the interactive controls. If the mods works with the interactive controls they still work.