Rebel Galaxy Cheats and Trainer for Steam

Rebel Galaxy
This is the official discussion topic of the Rebel Galaxy Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Shield
3. Easy Kills
4. Unlimited Ammo
5. Unlimited Boosters
6. Rapid Fire
7. No Overheating
8. Unlimited Deflectors
9. Unlimited Credits
10. Custom Warp Speed


Trainer Video:

Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 03/16/2017
    Started development

  • 03/16/2017
    Released trainer with 10 cheats

Like what you see?

Check out all of the games WeMod supports here.


Hi There Infinity has a problem for me in that rebel galaxy doesn’t come up on the games i own and if i try to pick which folder it is in it still doesn’t come up is there any way to fix this?

What is your game exe name and folder structure? This game has different exe names for steam/GOG so that’s the issue.


Steam’s path and folders:


C:\Program Files (x86)\Steam\steamapps\common/RebelGalaxy and (i think) RebelGalaxySteam

The Rebel Galaxy trainer has been updated!


  • Steam version support.

Please post in this topic if you run into any issues!

infinity now recognises rebel galaxy but when i start it (through infinity) it says first that the mods were not tested with this version i click yes to start the game and immediately it says it takes too long to load

Yeah that incompatibility message is fine. Ignore it.

Attach infinity after the game is running. Also run infinity as admin. If that takes too long error pops up immediately, it means permission error.

i ran infinity as an admin and it still came up immediately that it is taking too long to load and even when it try it when the game is running the same thing still happens

Read the error - took too long to load and the best practices section. I think it is an antivirus issue.

There is nothing else that seems to be the issue here.

I’m having the issue where despite pointing Infinity at the correct location, it is not detecting the game. I’ve tried both D:\GOG Games\Rebel Galaxy, which is my default, and then I tried reinstalling to C:\GOG Games\Rebel Galaxy, but still no luck. Also tried disabling AV for a bit.

Running Win 10 Anniv. update.

Any advice?

I don’t know what to do here. I changed the trainer to support steam version for The115Hoxton but now it won’t detect GOG. Until infinity v2, there is no way for infinity to support multiple game exes.

What you can do OldDaedalus is rename your game exe from RebelGalaxyGOG.exe to RebelGalaxySteam.exe and then point infinity at its location.

Beta Client Cheats don’t seem to work for steam.

Don’t post here, only in beta thread.

so this is an old thread but i am just curious and want confirmation that this cheat does not support origin?

Post origin game folder structure.

So I was playing with it normally but then it decides to crash whenever I continue from where I left off, help, please?

EDIT: It’s fine, I just had to use “Manage Saves” button and load from there

It keep saying that Rebel Galaxy is not a valid installation of the game. it was downloaded through origin, how do I correct this?

Do et

it still says the installation of the game is invalid