App Horizon

Rgh/jtag having trouble installing Skyrim title update

Anybody really good with aroura here? I just want to install TU because doing it manually with aroura has been a pain in the ass. Any help or advice is greatly appreciated.(update) So I was able to get onto unity market place. All’s I wanna fkn do is apply a title update for skyrim. I’ve tried doing it manually and it wont work. I got onto arouras marketplace and it was letting me enable it and everything but its still showing up as TU0. I had no problem installing my oblivion title update with unity but I’ve been trying for a very long time to get this thing to read the update.

Probably best bet is asking over on thier forum that made Aurora already forget the name of the place. I had a dual nand rgh so I was able to go online with the regular side of the xbox live and download stuff then switch over to the rgh side. So I’m not familiar with that stuff

1 Like

Thankyou I will look into their forum

1 Like

Once again horizon saved the day and allowed me to inject the TU into the USB and it is now working but only when I have the USB plugged in. I tried moving the TU to the hdd and unplugged my usb but it wont appear. Now I just gotta figure out how to move it from my USB to my hdd while still having it enabled. Regardless horizon is proving to be a very useful tool as far as installing programs.

Are you sure you’re checking the correct hard drive after moving it? For example on my RGHs I have the internal hard drive and an external hard drive where I store most of my games. One of them also has the 4gb internal memory module so that was technically has 3 storage devices present when I attempt to move anything from a flash drive to it. I’ve never had any issues drag & dropping TUs or any other 360 files into Horizon, saving to flash drive and then moving to one of my RGHs storage devices. I always put TUs on the main internal hard drive and they always show up in game. If that’s how you’re doing it and it’s giving you issues then i would suggest to clear the cache on the main internal drive and then try moving it again.

1 Like

Ok so my setup is a bit odd. I’m using a Jasper Phat which takes the external hard drive but I have an adapter that connects it to a slim internal 120 GB. Or idk if its considered internal at that point. All’s I know is I use that hard drive as my main storage. Is there any specific folder I need to drop the TU into?

That’s technically the internal drive or we’ll just call it the dedicated 360 hard drive port. Do you have a sata to USB connector that you can use to hook your 120gb drive up to your computer with and then inject the TUs directly to it? I don’t why your having issues moving them from the USB drive to the 120GB but if injecting works then maybe do it that way. The 360 knows where to put the TU and does it automatically. If it’s not showing up at all after you move it then something fishy is going on. As far as a specific folder you’re only going to see those in Horizon when you have a device connected. On the 360 as you know games, games saves, DLC & TUs all just show up in the folder for that specific game.

1 Like

I was able to figure it out:D Thankyou

1 Like

Listen. I’ve been there myself many times with similar stuff. If you keep trying you eventually get it figured out. Glad you kept at it.

2 Likes