RGH Xbox 360 not working

What do I do?

Start it up by pressing eject and see if it boots into xell

Did you do anything like change a file location? If you didn’t flash it, take the HDD out, plug it into the computer, open it with party buffalo, search for launch.ini (if you use dash launch) and remove the default line

I don’t know how to change the file location and the eject button doesn’t work.


So when this happened to me, It was due to a bad plugin in dashlaunch. If the same problem is for you, you can probably boot up your xbox fine without the internal HDD. Try to Turn it on normally without the internal hdd, and also if possible remove the wifi card. If the bad plugin was related to a stealth plugin, this would most likely disable the plugin (From my past experiences) What I did was this:

Take a Flash Drive/USB and put Dashlaunch and Horizon on it.

Remove your internal HDD and Wifi Card if possible

Plug the USB/Flash drive into your rgh and boot up with power button

If the console reboots successfully, go into dashlaunch and remove all previously set plugins, then save the setting to HDD

reboot with flash drive and internal hdd plugged in, along with wifi card

Hope my note helped :stuck_out_tongue:

Just tried still doesn’t boot up :anguished:

You’ll have to flash it again with a NAND-X

Turn the console completly off, unplug every cable for 10 secs, start up the console with the controller, wait 3 seconds, then open the disk tray. This should start up the console without plugins, make sure just the power brick and hdmi, or whatever video input you have are the only things plugged in!