App Horizon

Sid Meier's Civilization VI Cheats and Trainer for Steam

This is the official discussion topic of the Sid Meier's Civilization VI Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Super Damage
3. Unlimited Moves
4. Freeze AI
5. Fast Construction
6. Fast Production
7. Fast Civic
8. Stop AI Civic
9. Fast Research
10. Stop AI Research
11. Add Gold
12. Add Faith
13. Add Envoy
14. Drain AI Gold
15. Drain AI Faith
16. Drain AI Envoy
17. Get All Resources
18. Drain AI Resources
19. Max Population
20. Unlimited Builder Usage
21. Stop AI Production


Important Notes:

Click here to view important information about these cheats.

MUST READ BEFORE USING

Start actual game play first before using any mods, if you come upon a loading screen after activating your desired mods or restart mission then all of the mods will be disabled automatically and you will have to reactivate your desired mods after loading completes as this game dynamically rewrite its instruction on loading screen.

P.S: These mods are for DX11 version of the game.



Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 10/26/2016
    Started development

  • 03/16/2017
    Released trainer with 21 cheats

  • 04/20/2017
    Bug fixes and game compatibility improvements

  • 08/07/2017
    Disable All Mods cheat added
    Updated notes

  • 03/01/2018
    Bug fixes and game compatibility improvements

  • 03/28/2018
    Bug fixes and game compatibility improvements
    Updated notes

  • 04/25/2018
    Bug fixes and game compatibility improvements

  • 10/27/2018
    Bug fixes and game compatibility improvements

  • 10/27/2018
    Bug fixes and game compatibility improvements

  • 03/13/2019
    Bug fixes and game compatibility improvements
    Updated notes

  • 05/23/2019
    Bug fixes and game compatibility improvements

  • 07/20/2019
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

3 Likes

Sweet hope i get the game soon to try it out

Doesn’t work, cheats failed to initialize. I disabled my firewall and tested, still doesn’t work.

Yup. Doesn’t work.

I appreciate the work you guys do, but why release a trainer that doesn’t work?

works for me, but fast research crashes the game after you take a turn.

1 Like

@Bobmon The trainer works but there is some bug with infinity launching. Each trainer that we release is tested and not blindly released. If we did that, this trainer would be out way before game release

1 Like

do you guys know about the fast research crash or is it just me? haha

1 Like

How do I fix said bug?

If I run the launcher as an administrator, if fails to initialize or whatever. But if I don’t run the launcher as administrator, I get in game and then attempt to use say for example the gold cheat. It will make a little beeping sound but doesn’t increase my gold.

Not sure if this is problem on my end… If so, should I reinstall Infinity?

@Bobmon try to activate the cheats you require right after the game starts. there are a few bugs with infinity v2.0 but as soon as those are fixed it will start working normally.

Also the gold cheat takes effect after you take a turn.

Here is what I tried.

First attempt.

  • Launched Civ 6 through the infinity launcher
  • Started a game
  • Pressed F11 for the gold cheat. The little beeping sounds happen.
  • Advanced to next turn, it didn’t add 5,000 gold.

Second attempt.

  • Completely exited Infinity.
  • Loaded Civ 6 without infinity launcher
  • Started a new game
  • Loaded Infinity Launcher and pressed “Launch Game”
  • Tried to use F11 for the gold cheat and it straight up crashed Civ 6.
2 Likes

Hi there, I’m having trouble enabling the cheats as well. I have no problem getting the game running through the Infinity launcher in admin mode, but in-game none of the cheats seem to work. And I’ve gone through multiple turns waiting for them and trying different combinations. Un. health, super damage, Un. moves, fast con, fast prod, fast civic, fast res, and add gold. I’ve tried all and none work for me. When waiting a couple turns didn’t work, I started a new game with them already on, then toggling them on once into a new game. Nothing works, please advise. Also, something maybe for a change in the future, either f6 or f7 is the quickload button and erases a couple turns of activity. Just a suggestion, but maybe map it to the number pad.

One update, I’ve also tried enabling the cheats at the start of the game, right after the dev titles. and hitting the add gold in game again on the first turn after establishing the city. Waited 5 turns, got research and production going, still nothing works. What’s wrong?

Doesn’t crash the game, but it’s not working either. Seems they really fumbled the ball with the 2.0 release. Not only is it creeping ever closer to Windows 10 invasiveness but it’s also not working. I miss the old infinity, skynet feature bloat “go pro now for your free one week trial” is not the infinity I want. It’s only a matter of time before they lock everything behind a paywall anyway. I guess it was good while it lasted.

after being waited long time rhe trainer dosnt work . old infinity was better than new infinity.
bye the way The trainer dosnt work

@Tamassran What do you mean by invasiness?

Also i think you’re exaggerating a lot, infinity is completely free.

I’m just incredibly disappointed and in a bad place right now so I took it out on your thing because it was the first place I could vent. It was unwarranted. Regardless, You used to be able to launch infinity and use it with no website interaction, now you have to launch it from the website after logging in, that’s by definition more invasive than before.

Look, bottom line, it’s a good program, but you’re going in the wrong direction by requiring more and more of the user to actually use it with every update; It’s like feature bloat, kind of. I’ll keep using it and supporting you as long as you don’t make the mistake of locking all content behind a paywall instead of just pro content, which is understandable.

they are not locking it behind a paywall, Im pretty sure they want it always free, and right now Pro features are lacking but they are more concerned with fixing the problems.
I think it would be cool if they let Pro have Popular/new release games, trainers for a few days before everybody else(this would also help get any kinks out of the trainer the devs missed) 2 birds one stone so to speak

Trainer is not working. wondering wether its new infity error or the trainer itself

Seems to be an Assembler issue with the latest version of INFINITY tool, and not directly related to the Trainer itself, IMO.

If there is any bug with the assembler, then the trainer/cheats may or may not function properly.

I tested out the civ trainer now and it does nothing, the trainer works on the games i knew it worked on before 2.0. but it does not work on Civ 6. i tried all of them and no change