App Horizon

The Elder Scrolls V: Skyrim Special Edition crashes when using a trainer

Every time i use the trainer for TES SSE it crashes when I do anything.

1 Like

Hello there!

Unfortunately your post does not contain enough information for us to provide support.

The majority of crashes are hardware related, with the second biggest cause being related to the game itself. Looking at the two official threads for this trainer, there are no other similar reports recently.

  • Which store did you get your copy of the game from? Or is it cracked/pirated?
  • Are you using the special edition trainer or the standard edition trainer?
  • Are you using MrAntiFun’s special edition trainer, STiNGERR’s special edition trainer or have you tried both?
  • What error message do you get when you crash? Provide a screenshot if you can.
  • Do you have any other third-party mods installed on the game (ie, player-made game enhancements from NexusMods)?
  1. Steam
  2. SSE
  3. Both
  4. none it is freezing and crashing.
  5. no

Hello and thanks for the additional information.

Use STiNGERR’s trainer, because at the time of this post it is the most up to date version.

The fact that there was a freeze before a crash tells me it’s probably hardware or game related. These kinds of crashes are usually your computer deliberately killing the game’s process because of an issue with it. Chances are if it was a WeMod related crash then there would have been an error message from WeMod.

  1. Make sure your computer meets the minimum specs to run the game smoothly. As far as I recall, special edition has significantly higher hardware requirements than standard edition.

  2. Verify the integrity of the game files via Steam launcher. This checks for corrupt and missing files then replaces or repairs them. Here’s how to do that: Verify Integrity of Game Files - Steam Support.


When you’ve done that:

  1. Launch the game first via Steam launcher. Wait on the main menu for five minutes.
  2. Alt+tab to WeMod. Press Play.
  3. Alt+tab back to the game.

If you’re still having an issue:

  1. Use the trainer with the game until the game crashes.
  2. Click the down arrow in the top-right of WeMod, next to your username.
  3. Go to Settings. Scroll down to the “Save Log” section.
  4. Download the log as a .txt file and then upload it to a reply in this thread by clicking this button on the toolbar:

Still crashes

Then as the post asks:

I’ve been getting a freeze as well. For me, it only occurs on the skill tree after I’ve leveled up and need to select magicka, health, or stamina. After I click the option I want and the confirmation notice for “ok/cancel” pops up, no matter what I click the game freezes. I tested the skill tree without any WeMod options activated and it worked fine. Once I activated anything, then leveled up, the same freeze occurred. I am using some mods, but nothing that alters perks or skill tree. Game files verified, using STiNGERR’s standard trainer, legit game copy on Steam, no error message, just have to end task in the task manager. I have not tried MAF’s trainer yet, but will give that a shot to see what happens.

Also I tried to upload the log but got a message saying new users can’t upload. As long as I don’t level up and try to increase perks, the trainer and game run fine.