Total War: ATTILA Cheats and Trainer for Steam

The Total War: ATTILA cheats have been updated!

Changes:

  • Released trainer with 21 cheats



Please post in this topic if you run into any issues!

1 Like

fast recruiting , fast research , fast construction doesn’t work. Also stats doesnt work.

god mod doesn’t work

I just saw this thread so I will post what I posted a little further down:

Hi there, I’m getting this infinity address oxb4b104 coming up whenever I press the play button. It says it is an internal exception occurred? Any ideas?

Hello @Taigan. I’ll try to help with this.
Note, however, that if you have a cracked version of the game then there is nothing we can do other than advise you to buy the game legitimately. Cracks are incompatible with many trainers. Otherwise read on.


  1. Using the Add Or Remove Programs feature in Windows, completely remove WeMod from your PC.
  2. Disable your antivirus, even if it’s just the default Windows Defender.
  3. Download and reinstall WeMod via this direct link: https://api.wemod.com/client/download
  4. Once reinstalled, add it as an exception in your antivirus before you launch WeMod.

Once you have reinstalled WeMod, log back into your account by clicking the down arrow in the top right then selecting “Switch User”. Then:

  1. Launch the game first via Steam.
  2. Wait until you are on the main menu.
  3. Alt+tab to WeMod, press Play.
  4. Alt+tab back to the game.

If you’re still having an issue:

  1. Go to settings by clicking the down arrow in the top-right
  2. Under the General tab, switch from Stable to Beta release
  3. Close WeMod via Task Manager
  4. Restart WeMod

Let us know if this resolves the issue or not. :slight_smile:

Worked just fine thanks very much

1 Like

Glad it works for you now. Have fun! :slight_smile:

Trainer doe snot work for me. It opens up and plays but say I entered F2 it says “on” for just one second then reverts back to “off”.

Are you using the most up to date steam version of the game ?
How bout antivirus ? That will cause them to turn on then off ?

Its working now for me. I guess probably the server was down but all good now. Thanks!

1 Like

Ok great glad you got it to work ! :+1:

Game crashes if i activate the trainer

Is your copy of the game legit or cracked?

Try this: Launch the game first via Steam launcher. When you’re on the main menu alt+tab to WeMod, press Play then alt+tab back to the game.

Legit version i bought on steam. i tried to load the wemod trainer after starting the game and before and it crashes either way. i even uninstalled all mods i had loaded and verified the games files

Some sort of internal exception error keeps showing up

Update please? Would be appreciated

cant toggle off once activated issues ex. god mode
not all generals receiving SP/Integrity/loyalty/stats (majority of generals do get it)

dose wemod work with other mods like kingdom 1212

No usually not. We recommend one or the other.
Some say they have and worked for a while then quit working.