Wemod 5.0.21 problem

Hi, I’m a new user to Wemod and I can’t seem to get the app to work at all.

I’ve tried to install the app through the download link that is supplied on the home page but this problem persists. I’ve tried allowing firewall access, turning off antivirus and even updated my Windows.

I’ve searched through the forums and found a download that allowed me to install Wemod version 5.0.21. I was able to install it but then all I get is an empty dashboard. Clicking games and requests doesn’t do anything. I can’t login to my account as well.

Tried some solutions but none of them seem to work. Any more ideas to fix this?

Yours Sincerely,

If you’re using an antivirus deactivate or better yet completely delete it off your system.

I already removed my antivirus prior to installing this. My Windows Defender is also deactivated for the time being.

I was thinking that this might be a problem related to the conection as from what I can see, the app is not able to communicate with the server for some reason.

maybe uac blocks the permissions to write downloaded files or your router is wrongly configured

Well if something is blocking the connection it’s something on your end.
Deactivate your firewall and try again.

Tried alot of stuff but still couldn’t get it to work.

I’ve tried disabling my firewall and windows defender. Tried administrator mode and even cleaned up my pc again.

Just for your info, I’m accessing this website through Firefox and have Windows 8.1. If I were to use Chrome though, this would pop up:

And of course it shows the same error as the app is facing.

Maybe this is what’s causing it?

That’s strange. I think it’s out of our control though - something with Chrome and installed root certificates.

Try a VPN. That error does not happen for me.

Okay I was finally able to fix the problem. It was Chrome that was causing the problem, with it not trusting the certificate that is given by the website.

So what I did was install the certificate that is given by the website.

The first one to be exact was not trusted by Chrome. So I had to export the certificate and add it to the trusted certificates in Chrome. After that I reopened Chrome and I was able to access the website!

Now I opened Wemod, and sure enough, it works!

Thank you guys for trying to help, and maybe can try to get the website url to be more secure next time.


1 Like