WeMod download error - Entry Point Not Found

Mine are all purchased from Steam, and yet wemod is not working. It worked until yesterday, but since them, never more. And now I’ve downloaded it again, but it won’t install.
What could be the problem?

Error message:

But my W7 is 64 bits.

Oh, and I’ve disabled Defender and antivirus. And downloaded and installed the setup file many times.

Firstly, please download .NET framework 4.5.0. WeMod requires it to work and it does not come with Windows 7 unless manually downloaded. It’s possible that any existing .net framework on the PC may have corrupted. Which just happens for no apparent reason sometimes.


I split this topic into its own thread since it’s a different issue to the original thread you posted in.


Framework in a higher version. Or it has to be 4.5?

Try installing this update: https://www.microsoft.com/en-us/download/details.aspx?id=26767

Funny thing. It was all running well, until I had to format my PC last week. Then, after installing all again, I had a lot of problems with Wemod. Then I found the setup file in the backup (I forgot I had it), and installed it, and it worked. For about two days.
Then I went to open it again, through the shortcut, and it was dead, saying the original file was deleted. I searched for it, and it wasn’t there anymore. Nobody here to use my PC, and I haven’t deleted it. I turned everything off for the night, and next day, it was gone. And now I can’t install it anymore.

Well, I’ll try this one. Let’s see if now it works. Thanks.

1 Like

That’s really strange. Not sure why that would happen.

If you still want to install the .NET Framework, I suggest installing the latest (4.8): https://dotnet.microsoft.com/download/dotnet-framework/net48

I have 4.y. I assume it should work. I’ll try that update you linked before. Then I’ll try this new network.

Someway it must work. Even if I have to wait for the correct alignment of the planets… he he

The update is not applicable on my computer…

Just found a working app here: C:\Windows.old\Users\alelizio\AppData\Local\WeMod\app-6.3.10

Already installed and ready to run…
I wonder if it’s gonna work if I only move it to another file…
Never mind. It opened until I started a game. Then it just crashed and won’t open again.

Could it be because I was with VPN on? I need it for work. And I only leave it on during working hours, then I disconnect it. But it wasn’t an issue before…

It could possibly be the VPN. But first, try moving that out of Windows.old and into your normal folders.

Tried it. Got this:

It still opens, but when I try to open the game from Steam, I got this, again:


Already disabled antivirus and defender.

Then I try to install it again. I go to Wemod website, download the setup, again, and on installing it, I got this:


It goes all the way to 100% to tell me that. I got it from WeMod-Setup file. When I get WeMod-6.3.10 file, it gives the same error message, but won’t even start the instalation.

Try putting the files in AppData\Local. Basically where it was before minus the Windows.old folder.

Thanks for screenshots, they help a lot.

1 Like

No problem. Screenshots are totally necessary, otherwise how can I get help without being clear?

About the wemod I had, I went nuts and deleted it completely. I don’t know what to do anymore. I don’t want to format my PC again because of home office. When this quarentine ends, and I have to return to office, I’ll format my computer again and try Wemod again.

But thanks for the help. And keep on with the good work. Your app is amazing!

As a last resort, give this a try: https://storage-cdn.wemod.com/app/releases/stable/WeMod-6.3.10.exe

Hope it works :confused:

1 Like

Same case. Same error message.

Now, if I can find these “Set Default DLL Directories” and put them into kernel32.dll (it should be kernel64, since I’m running a 64bit windows), would it work?

No, those APIs should be available with the update link I posted. kernel32.dll is the name on every system, and you can’t add APIs to it outside of applying a system update.

This seems to be the same update, but targeted specifically for 64-bit systems (might work?): https://www.microsoft.com/en-us/download/details.aspx?id=26764

Aside from installing that, .NET 4.8, and all the optional Windows Updates, I’m at a loss with what to do.

1 Like

It worked!

With the last update you gave me. Didn’t even need to install framework 4.8. Mine is 4.7, but it’s actually working.

Thanks a lot, Frank. Now my only problem would be staying away from gaming so I can work… he he

My best to you and all of Webmod team!

1 Like

Awesome :smiley:

Let me know if anything else arises. Thanks for your patience resolving this!

1 Like

I thank YOU for your patience. And don’t worry; if any problem comes to happen, I’ll bother you again. he he

1 Like