WeMod game launching issue

I have been using WeMod without issues for years. And now I am having this same issue. I have done the following steps to try and resolve but I am still having the issue:

  1. Whitelist all wemod folders and .exe files in AV
    a. Also whitelisted all steam directories
  2. Uninstall WeMod
  3. Delete WeMod folders from appdata local and roaming folders (which is a terrible install location FYI)
  4. Verified registry entries were removed with uninstall
  5. Restarted my PC
  6. Disabled my AV
  7. Reinstalled WeMod from fresh download
  8. Launched WeMod
  9. Switched to Beta build
  10. Waited for update to download and prompt for restart - Restarted
  11. Force closed WeMod from Task Manager
  12. Ran WeMod as an Administrator
  13. Attempted to launch a game - Same issue.
  14. Told WeMod exactly where to find the .exe for a game
  15. Attempted to launch said game - Same issue.

Every post I have read this morning that seems to be having similar issues, everyone keeps blaming AV but everyone is using a different AV. I am using ESET for my AV. I don’t think this is AV related.

This is the error I get when trying to launch any game at all.
image

To be clear, the game does not launch at all. The play button will circle several times and then this error comes up. I also went digging into Event Viewer but WeMod apparently doesn’t log anything there or into either app data folder.

EDIT: Also just to be clear, tried launching several games, new ones that I have never used WeMod for and old ones that I have used WeMod for and got the same issue on all of them.

Are you on the STABLE or BETA branch of WeMod? :slightly_smiling_face:

I originally was on stable, but as I said on step 9, I switched to beta as part of my troubleshooting.

This does look to be AV related, ESET looks to be quarantining our auxiliary EXE which attaches to the game process for the trainer to work.

Try white-listing this EXE

“C:\Users\YOURPCUSERNAMEHERE\AppData\Local\WeMod\YOURCURRENTWEMODVERSION\resources\app.asar.unpacked\static\unpacked\auxiliary”

Added the EXE to the exclusions for all versions just to be on the safe side
Tried again and still not launching.
Disabled AV real-time protection
Tried again and still not launching.

Anyone else have any suggestions?

Try this one if this dont work get rid of ESET AV
https://api.wemod.com/client/download

Already did a reinstall with the version that download provides, see original post.
Am currently running version 6.2.17-Beta.2

Just uninstalled ESET, restarted computer. Disabled windows firewall. Not running any AV at all.

Still having the same problem.

This is not AV related.

@frank Any input on this?

What version of Windows are you on? Are you perhaps due a Windows update?

WeMod’s dev, Frank, helped me to figure out that a similar issue I was having not too long ago was because my Windows 10 OS was out of date by over a couple of years (oops, lol).
I understand that some people don’t want to update to the latest version of Windows because Microsoft keeps introducing new problems and new pointless bloatware, I was in the same boat. But it did fix my issue which seems similar to yours.

After the error message pops up, navigate to app settings, hit the Save Log button, and send me the resulting file. Hopefully that’ll be enough to see what’s going on here :face_with_monocle:

Winver is 1903 build 18362.592, I am going to go ahead and upgrade to 1909 and test again after.

Here is the log.WeMod.log (14.7 KB)

Holy ■■■■ I figured it out thanks to you.

So I went to get my version info from cmd, was going to run winver. I noticed when I launched cmd it would open briefly and then just close out. Obviously a problem but I assumed un-related.

After I did the steps @frank suggested and after upgrading to 1909, I did some digging into my cmd issue. Turns out I had at somepoint been infected with a miner of some sort that had created a registry entry at [HKEY_CURRENT_USER\Software\Microsoft\Command Processor] that basically said anytime cmd is launched, to close cmd and open the miner.

Deleted the registry and now I can open cmd and I have verified that I can use WeMod again.

Thank you @Instinct & @ptondo for the assist.

3 Likes

Awesome glad you finally figured it out. ! Have fun :+1:

Wow what an intense ending, I’m glad you figured out the issue. Crazy that it was a rogue mining program :confused:

Wow, I had the same problem, deleted that “Autorun” registry, and now the command prompt and the cheats are working again. Thank you very much!

1 Like

hello there … i am sorry but it seems that i have the same trouble and i can’t find a solution

Small edit : my games mostly not supported … most of them Pirated :smiley: so is that the problem or what
the app runs my games fine aka the game starts up but the App itself keeps telling me the same message that is shown above in the topic (We’re Having trouble starting or finding your opened game) but the game is running so can any one help me :slight_smile:

Yes that’s a big problem, Games get updated all the time so do the trainers.
Pirated games had altered code so make them work. Because of this the code is different for when trainers are made. If they work they work, But the trainers are made for legitimate copies of games.

Yes inkboti is correct we dont support cracked or stolen games on here. Need to legit buy the game from the store like steam , epic , windows

1 Like

Shame :confused: … thanks for the help anyway … tho i must say iam little disappointed that it don’t support cracked games i really liked the idea of the WeMod