WeMod launches Just Cause 4 but doesn't hook into it

I’ve used WeMod for quite some time, even back when it was called Infinity, and it’s never had any problems… until now. The Just Cause 4 trainer has a major problem with it, at least for me - clicking Play launches the game, however none of the toggle buttons do anything. I have sounds on, so I would know if they’ve activated.

After alt-tabbing out, I can see what’s happening. The Play button on the trainer spins around for around a minute then brings up an error message stating “We’re having trouble finding or starting your opened game.” All other trainers work flawlessly - I have a legally-purchased Steam version that’s been updated to the latest patch. The trainer says that it’s supported, so I have no idea what’s going on here. Reinstalling both WeMod and the game didn’t help.

Edit: I should mention that the trainer by REPPIN is having this issue. The trainer by STN hooks in and the toggle buttons work, however STN’s trainer is outdated and only one of the cheats works.

Can try and start the game from steam first then when you are in game alt tab out then press the play button in wemod after game has started

1 Like

In addition to what the awesome @ptondo said above:

  1. Click the down arrow next to the Play button in the trainer.
  2. Set a custom path to the game’s .exe on your PC, even if it looks correct.
  3. Try again, but doing as Ptondo said (Launch game first, when on the main menu alt+tab, press play, alt+tab).
1 Like

ptondo’s proposed solution doesn’t work, it still spins around then displays the same error message.

Your proposed solution also doesn’t work, identical results to ptondo’s solution.

I shouldn’t have to alt-tab out at all or set custom paths since an outdated trainer hooks in without any issues, so why should I have to do extra steps using a trainer designed to skip extra steps?

Where is you copy of the game from. ?
Alt tabbing out is just another 2 second workaround some games can be picky.
Other games are working for you ?

Actually, with roughly 40% - 45% of modern games, you do. This is due to the way the game is made and there is nothing WeMod, or any other trainer provider for that matter, can do about it.

Also are you sure you’re playing Just Cause 4 and not Just Cause 4 Reloaded or Just Cause 4 Complete Edition? These are all different softwares and hence may or may not require different trainers.

All other games and all other trainers work fine if they’re updated, and I can launch said games from WeMod without any issues. As for the version, yes I’m 100% sure I bought plain old Just Cause 4. I did buy DLC, but after the fact. I still don’t have all the DLC. I purchased the game on Steam and it’s in my Steam Library, so I own a legal copy. I know the problem is with WeMod since the outdated STN-made trainer launches the game without issues, successfully hooks into it, and the toggle buttons work. However it’s no use to me because the game has updated several times since STN’s trainer was made and not all the options work.

Okay, I have a bit of an update. I somehow got the trainer to work, however reloading any gun while Infinite Ammo is active crashes the game. The trainer says it’s compatible with the latest version of Just Cause 4, so I have no idea what’s going on. It’s just one issue after another. The new update to WeMod didn’t fix it.

Edit: I tried a few things and realized that Infinite Ammo is the ONLY one that doesn’t work. Since you run out of ammo too quickly in this game, this is one I desperately need.

Well glad you finally got it to work. Use the no reload works about the same way sometimes :+1:

Okay, I have some bad news. I did some more testing and it’s not working. I launched the game with No Reload like you said, and Infinite Ammo works after reloading a few times. However, Infinite Wingsuit Boost doesn’t work anymore.

I the closed the game and launched it again - now Infinite Wingsuit Boost AND Infinite Wingsuit Missile don’t work. It seems that cheats randomly stop working each time you launch the game.

Edit: It also seems that the Infinite Heath cheat doesn’t work as described. The description says quote “Unlike infinite health mods that constantly refill your health, this cheat makes you completely invincible”. That’s false you can still take damage and dying inside a vehicle forces the game into a permanent zoomed-out slo-mo state that you can only get rid of by quitting the game entirely. You can even see the screen getting red, proving this to be false.

Edit 2: I just died to my own wingsuit missile with Infinite Health ENABLED! It apparently doesn’t work. I had to Ctrl+Alt+Delete to quit the game as it wouldn’t let me pause.

Edit 3: I launched the game a third time and now Infinite Health also doesn’t work. Seriously, what the actual crap is going on here and why is only affecting me?