WeMod Linux/Steam Deck launcher is in development

A WeMod Launcher to automate the installation is being worked on. I’m helping to test it out, it definitely feels almost ready, just keeps messing up on winetricks right now. Dani, the developer is currently reworking the launcher to use the offline DotNet installer my tutorial uses, but we have at least one person who successfully got through the winetricks so feel free to test it out. Once its ready, this will be the best unofficial way to get WeMod on Deck/Linux. The full github page is right here

It’s still early in development, so it might work properly but don’t expect it to. if you want to check it out open the Konsole and type,

git clone https ://github. com/DaniAsh551/wemod-launcher.git -b ‘feat/automated’

Just remove the spaces, then put

WEMOD_LOG=/home/deck/wemod-launcher/wemod.log /home/deck/wemod-launcher/wemod %command%

in the launch options for the game you want it on. Set Proton to GE 7-38 and then click play. This doesn’t require Proton-6.19-GE-2 because it bypasses using the offline installer, instead pulling the WeMod_bin folder from the latest installer on its backend, which has all the required files. The full github page is right here

DaniAsh551, the developer, can be found on Reddit here

If you want to test it out, the git clone command will install a wemod-launcher folder to home/deck, you put that argument in the launch options and click play, then the launcher will start. It will download the latest WeMod offline installer and extract the wemod_bin folder from inside it, which has all the important bits. It will then attempt to install DotNet 4.8 with winetricks, and this is where most of us cannot get past. Regardless of it it works or errors out, the moment the launcher starts it will generate a wemod.log file. Send that file to Dani so he can have a better understanding of what’s going on. Now, if it doesn’t work, in the short term this launcher makes my method a lot faster and easier because all you need is to install DotNet through Steam Tinker Launch and then set the Wemod.exe in the wemod_bin folder as a forked custom command in STLs game menu. Once the launcher is complete my method will be obsolete since its very tedious, but for practicality its still serves a purpose at this stage.

1 Like

There is a discord for anyone who wants to help test it out

Seems to work perfectly.

Does the WeMod build steps have to be done for each game, or after the first time, the launcher option can be copied to any game?

I believe you have to manually do each game I could be wrong though.

If you want to you can join our discord we have a channel listed guide-feedback, The team hangs out in there. WeMod does not provide official support yet for it but we have provided a channel for support from the developers.

1 Like

I can’t see the guide-feedback channel in Discord. Did something change?

Make sure show all channels is selected on discord

So is it live?

I guess not.
Sad. To have a working Wemod on SteamDeck is still the case…

The launcher from Dani is live. WeMod is not working on a steam deck launcher, Linux support, etc. at this time.

@ DaniAsh551

After I figured out minor typos I was making, it installed smoothly, including the Net 4.

Using Linux Mint Cinnamon (prefer KDE, but we can’t all be happy :^P ).

I AM having 1 issue though…
I bought the GoG pack (includes Metro 3033, Last Light, Exodus, and a couple of DLCs that I never heard of), I can run it fine on the GoG app… but this WeMod is the only way that I found to run a trainer (I couldn’t get CE to work correctly)…
BUT, I had to link to Steam as a non-Steam game (and it runs fine), but I haven’t figured a way to link the WeMod to the game.
I can choose “Add Game” → “Add Custom” → choose the exe from the folder it’s installed in, but WeMod doesn’t recognize it, for some reason.

I will play around with it some more tomorrow.

I always used WeMod when I was on Windows, and it is great to see it being worked on for Linux!

Thank you DaniAsh for making the time and effort to do this (and PLEASE don’t give up now!).

P.S. There is 1 problem I did have while installing.
The game wouldn’t run, so I checked the log file, and it said that I didn’t have “tkinter” installed.
After a little research, I learned that I needed to install python3.
So, in the terminal/console, I input “sudo apt-get install python3-tk”.

The installation went smoothly after that.