WeMod not working on Halo MCC CE

I am running Halo CE through steam. Once the game is at the main screen I run WeMod. I select play and it changes to playing. When I select the toggle F1 it changes to on on WeMod. It also makes a beep. But when I am playing the game the cheat doesn’t work. I am able to toggle the cheat on and off in the game, but like I said it doesn’t work. Has anyone got any ideas on how I can fix this.

Welcome to the community. :slight_smile:

Which store did you buy your copy of the game from? Or is it cracked/pirated?

Please make sure you have selected the correct trainer from underneath the game title in the WeMod desktop app. Each game in this title requires its own separate trainer.

1 Like

And also its for singleplayer use only. Not for online

I bought the game on steam. Its sort of working. I had Halo Reach selected instead of CE. The cheat works but I cannot toggle it off. Any idea why?

Can confirm Wemod trainer does not work in Halo Master Chief collection Steam edition. I’ve tried it for every game and it simply has no effect.