WeMod remote app not working!

So i wanted to try Remote wemod app on android but its not working it connect to pc and says Open The WeMod App on your Pc nothing more tried web version it works fine. Please fix this old issue more than 2 year old post with same problem. Good that im on 3 day trial so i know its not worth to pay for this pro if its not working im not going to use web version when you promised that i can use remote app on android with wemod pro and promises newer given. Sorry if its sound rough im just really pissed i was so happy with finding this feature until i tried and it didn’t worked as intended… Btw tried all troubleshooting methods nothing worked.

Try going into the settings on the app on your phone and clearing all data for the WeMod app and then try again :slight_smile:

like i said i tried everything

devs should look at play store ratings dropped to 3.0 stars 2/10 ratings talking about this same problem…

We addressed and resolved the issue with you on Discord. But for others with this issue who might stumble upon this thread:

  1. Launch Task Manager. Locate all instances of WeMod (including under the “Background Processes” header).

  2. Right-click and select “End Task” on all WeMod processes.

  3. Close the app on your mobile device.
    You need to close the app properly, not just press the home button (this dismisses it to the background where it is actually still running). Closing apps correctly involves swiping them.

  4. Re-launch both and try again.

If the issue still persists, go to https://remote.wemod.com/ and see if you are able to use the remote from there.

  • If you can use the remote from that link, then the issue is with your device’s interaction with the app. For example, a security program blocking the app’s connection with WeMod’s servers.
  • The app and that link are both the exact same thing.
  • You can place a shortcut to that link on your device’s screen/list of apps and use it instead of the one you downloaded from the app store.
1 Like

Same problem you need to force stop the remote on your phone then clear cache and storage’s app. Have the app running on your pc then reopen remote on your phone and it should work.