App Horizon

Xbox 360 MineCraft Freezing on World Load

Is anybody else getting the problem where when you load your MineCraft world on the xbox 360, it will finish all the setting up then when it says it is initializing, it just freezes? I have no idea why this is all of the sudden happening, I have tried clearing system cache, that did nothing.

The game is only 100mb just delete it and re-download, See if that helps.

Just tried to do it, did not work.

It is probably your save then. Try putting it on a USB and start it up without it.

I really had a feeling on that one, but nope, didn’t work.

You probably turned your xbox off/dashboarded while you were saving or the game was auto saving, in this case your world is corrupt and you’ll need to start a new one.

Hmm, happened to me 4 times in a row. It’s fine now.

Also it sometimes freezes when exiting the nether.

I don’t know how I fixed it, I just restarted my console and it was fine.

Theres a glitch in the game that needs to be patch. Worlds don’t load for me neither,It takes time.

I figured he corrupted his save in the past but I left to main menu earlier and left my Xbox idle while I went to pick something up to eat, when I came back the world wouldn’t load. I just made a nether portal earlier.

happened to me yesterday. i think it just glitches up some times.

Your save probably became corrupted somehow. A day or two ago my save got corrupted and the world wouldn’t load at all. I’d click it and it would just go to the part where it loads but the loading bar wouldn’t even appear. Later it would start to load but then freeze the console.

Back up your worlds to a usb after major builds. That’s what i’ve started doing.

Weird. Wonder how it got corrupted? Maybe am inventory problem? Because I have modded my inventory, a few days ago.

Yes, I’ve had the same problem, as well as my brother on his seperate 360. Tried 20 times with the game freezing my 360 about 10 seconds into my old world. What worked was to make a new world and try out the new features “Creative Mode” then going back and reloading my old world, and it worked fine with no problems… well all crates are now black but you just have to make new ones.
Hope this answers your question :thumbsup:

Hi, this also happened to me after messing around on with my world on Universal Minecraft Editor. My world was misbehaving until it crashed and whenever I would load my world, “initializing server.” appears and the bar doesn’t even start. The whole console crashes and I have to restart it. But all my other worlds work perfectly fine. I built so much stuff in my world. Me and my friend took days to build it. Please, Help!