XCOM 2 Cheats and Trainer for Epic Games

This is the official discussion topic of the XCOM 2 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Supplies
2. Set Supplies
3. Intel
4. Set Intel
5. Elerium
6. Set Elerium
7. Alloys
8. Set Alloys
9. Max Supplies
10. Max Intel
11. Max Elerium
12. Max Alloys
13. Health
14. Set Health
15. Mobility
16. Set Mobility
17. Aim
18. Set Aim
19. Will
20. Set Will
21. Armor
22. Set Armor
23. Dodge
24. Set Dodge
25. Hack
26. Set Hack
27. PSI
28. Set PSI
29. Unlimited Health
30. Unlimited Mobility
31. Unlimited Aim
32. Unlimited Will
33. Unlimited Armor
34. Unlimited Dodge
35. Unlimited Hack
36. Unlimited PSI


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 04/14/2022
    Started development

  • 04/14/2022
    Released trainer with 36 cheats

  • 05/04/2022
    Bug fixes and game compatibility improvements

Like what you see?

Check out all of the games WeMod supports here.

1 Like

The XCOM 2 cheats have been updated!


  • Released trainer with 36 cheats
1 Like

Heya, can we get instant? Like for example, i research something, and it will be instantly researched?

1 Like

I hate the cheats since there is no infinite turns or on hit kills so therefore I stopped playing the game.

1 Like

I think there is a console command for the first thing. Google for XCom 2 console commands on Reddit. It should be on that list (it’s a very informative post, too).

On the second thing, I don’t think they can do that since the devs didn’t create a one hit kill cheat in the game for testing (that’s part of what trainers do, turn on existing but hidden cheats). But if you’re invincible, you can still wear them down. I love XCom (all of them)

I hope that helps.

1 Like

None of the cheats seem to be working. I assume this trainer is the same as the steam one, and I already saw a comment on that one talking about how that one isn’t working either. Hoping for an update soon


works fine for me, only issue I had was the supplies one took a bit of fidgeting with.

1 Like

The cheat works well, but when you try save the game, it crashes.

All of the player stat cheats were working fine but I can’t get the resource cheats to work at all. Not even one of them. How did you do it?

Try using on the world map, activate the add resource and maybe move to a location. it takes a few seconds to register I’ve noticed.

1 Like

Is there any chance to have mod:

  • unlimited ammo / no reload
  • unlimited actions
    I tried to put -allowconsole in the additional command line arguments on Epic Game launcher, but nothing happen when I hit the “~” key in the game.
    Thank you.
1 Like

The mod does not work with the latest Epic version as the game runs from 2k’s own launcher instead of the native Epic app.

When I run the game from Wemod, I get the warning message at the beginning- "

these cheats may not work with your game version. Do you want to test them out anyway?

" Then after launching the game, the error message is the mod was created for 64bit version, but I was using the 32 bit version of the game. This error is there because of the 2k launcher. Can you look into these please?

1 Like

It’s not working for the Epic Games Version as of now. :frowning:

the “set supply” cheat does not work, please fix

Try launching the game first, and be on the main menu of the game. Past the launcher of course. Then hit Play on WeMod.

What isn’t working?

That’s what I did.
nothing is working.
(edit: to be more clear, it appears as “Playing” on the play button and all, but nothing changes ingame when a cheat is activated. I tried the F1-F8 and the +intel and +resources)
I now see that it’s on the update queue. I’ll be waiting, then!

The only cheat broken was the Set Supply value cheat.

With the other cheats, have you followed the cheat instructions? And tried going to the pause menu and back in after you used the other cheats?

1 Like

I did try that. still nothing. but also, where do I check each cheat instructions?

It’ll be the little i or ! icon next to the cheat name. The ! icon is for cheats that you need to follow the instructions for.
Try having at least 40 of the desired resource as well.

the only instructions there are the “change the X value before activating this cheat”
nothing different for me (also I did that and still no result)