Assassin's Creed Odyssey Cheats and Trainer for Uplay

I thought I was the only one.

1 Like

There seems to have been an update to Odyssey because teleporting now desynchronizes the player.
Version: Uplay/PC

When i Activate Tp to waypoint with num 9 it teleports me after a view seconds to some unterwater area and game crashes after that… what to do ?
please help
it worked then i close game and play on another day … since then it does not work

2 issues so far.

  1. xp multiplier dont work
  2. player damage multiplier dont work

steam version

Hi, the trainer won’t start for me. The software has trouble finding the game open, I tried several techniques but none of them work.

Uplay+ version

This trainer is for the Uplay version of the game, not the Uplay+ version.
You need to use this trainer: Assassin's Creed Odyssey (Uplay+) Cheats and Trainer for Uplay

1 Like

This trainer is for the Uplay version of the game, not the Uplay+ version.
You need to use this trainer: Assassin’s Creed Odyssey (Uplay+) Cheats and Trainer for Uplay

Ay, thanks!

Anybody else having issues with the XP/Damage Multiplier? When I use them. I get no xp and I do very little damage. I’d post this in the steam version. But the thread doesn’t exist anymore.

1 Like

The XP boost isnt working for me. Anyone else?

1 Like

god mode works, but it gives god mode to game characters also. They do not take damage, as long as i am god mode. So this is Broken.

1 Like

I am having problems teleporting. I just finished killing the last of the cultists, Aspasia. Hope that helps. I haven’t had problems with it before until I was after the last 3 cultists. Ever since I unveiled Melite, I’ve had issues with teleportation. So I went after them on foot. And there was Melite, Iokaste the Seer, and The Ghost of Kosmos if that helps either. I don’t know if it somehow disables Teleporting after you kill so many cultists, or if it’s just the trainer itself maybe just being buggy. Idk. Any help is appreciated.

The add ability point does not work for me on any save.

I still can’t get teleportation to work. I enabled the Teleporter, went to the map and clicked on a custom waypoint, pressed the hotkey for teleportation and still nothing. Please help

Same thing here. It crashes the game or just doesn’t do anything

I had this issue once before. Have you purchased all your masteries and abilities? I’m asking because if you buy every skill available you stop earning points nor will the cheat work.

Teleportation, for some strange reason, has suddenly stopped working. In my last playthrough it worked somewhat okay, not perfectly, but at least it worked. I had screwed up the last playthrough ( not saving when I should have) and had deleted all my saves. In this playthrough, teleportation, just never worked at all. Wonder why this has happened? Will it be fixed? Any help would be greatly appreciated!

Yes, I found that the Ancient Tablets resources aren’t working as well. In fact, if you have collected 1 or more Ancient Tablets and try to use this feature, it will reset your Ancient Tablets to 0 :rage: :rage: :rage: Something the Devs should look into.

Aside from that everything else seems to be working well. The Teleport function has a bug where occasionally it won’t work, but I found that if you move out of the general area you are in or Fast Travel to a Sync spot and try teleport again it usually resolves the problem.

why would my God Mode not work for me??? It is loaded in steam, but opens uplay first. [I cannot take damage, but neither can npc’s] Is an update needed for this game?

1 Like

I can concur that teleporting stopped working for me as well, only altogether for this game. It’d be real nice if the devs could fix it.

The trainer is up-to-date, please make sure you follow all cheat notes.


God Mode:

Resource picker:

1 Like