Assassin's Creed Odyssey (Uplay+) Cheats and Trainer for Uplay

This is the official discussion topic of the Assassin’s Creed Odyssey Trainer and Cheats.

The Assassin’s Creed Odyssey cheats have been updated!

Changes:

  • Released trainer with 14 cheats



Please post in this topic if you run into any issues!

Finally a working trainer for uplay+ version.
Thank You so much.

1 Like

The Frame Rate ingame drops secondly to 0 when i’m activating wemod… is this normal??

How come Uplay and Uplay+ are Separate? Does that mean game saves are as well?

The UPlay+ exe is different than the standard exe so it requires a different trainer.

1 Like

I understand, Uplay+ As for as I know you need to be online, Could this be banable? Wondering in case future trainers come out for games I do need Uplay+ for :slight_smile:

@LBailey94

I don’t believe you can be banned from using the trainers with Uplay+ games as long as you are not using them in a multiplayer setting. From what I can understand and I am making an educated guess that you only need to be connected online for DRM related reasons because you have not bought the game just a subscription to access these games.

2 Likes

Anyone here who hast problems with frame rate after activating the trainer on uplay+ ?

@jaccyy Nope, My game is fine but my rig is stupid

@Bmax12543 Thank you for clearing it up <3

the unlimited ability points dont working

Same here

@MrAntiFun I’m having issues where I can no longer use my bow abilities. Everything else I have activated seems to work. The options I have turned on are Unlimited Health, Adrenaline, Resources, Items, Instant Cooldown and when I’m on the ship I have Unlimited Health Ship and Ship Boost and I do use the Teleport Waypoint option a fair bit.

That happened to me when i was playing without any trainer or mods, i could not use my melee abilities anymore and had to create a new save and start again. Might be because of the trainer for you but for me it was just a game breaking bug

Sorry to hear that man. I will say i figured out a way to make the abilities work again. I just had respec all my ability points and once I repurchased them everything worked again. Idk if it’ll help anyone else but it’s worth a try for anyone else having that issue.

@MrAntiFun

First of all thanks for your trainer.
There are some issues : the unlimited ability points only gave me 147 points, not 99999…, also the teleport waypoint cheat doesn’t work at all.

Didn’t think to try that, will keep it in mind in case it happens again

For the teleport waypoint option do you set the way point first and then activate it? If you have it active when you set the waypoint it won’t work. I used it last night and it worked fine for me

1 Like

Oh I didn’t know it worked like that, thanks.
Did you manage to get the unlimited ability points working ?