App Horizon

Assassin's Creed Odyssey Cheats and Trainer for Uplay


#896

The options do exactly what they advertise. You level up :slight_smile: For cosmetics, check budabum’s item swapper (inventory editor) on fearlessrevolution.com. At this point in time I consider there are enough options to give you a pleasant playthrough :slight_smile:

BR,
Sun


#897

Hi there everyone!! I want to formally say thank you very much for all the wonderful hard work put into this magnificent trainer . The only thing I have to complain about is the new update has somehow changed the damage multiplier as someone else has mentioned I too have noticed this , and I was wondering is there a temp way to maybe install the older version before the update , or is that even possible or are we kinda stuck for the moment while it sits this way ? thanks in advance for all our attention to helping out if possible , I hope you can work out this little thing easily, and it will be very much appreciated by us all !! I have tried everything but then I read that it was just a simle error with c++ that needs to be done sounds like to someone this sounds easy idk though ? hope it comes soon but no rush , thanks again!!


#898

Thank u for the work, but the damage multiplier isnt work as the infinity adrenaline


#899

I’m sure others have reported this, however with the recent updates to this trainer I have found that Unlimited Adrenaline and Damage Multiplier is no longer working. I’ve checked in the app and the only version listed for Assassins Creed Odyssey is 1.12. I don’t know if the latest update has had this effect on all versions or not, but on my game’s version it no longer works. Would it be at all possible to add the previous version trainers? By the way your work is amazing and very much appreciated!!


#900

I really don’t know what to say. I’ve tested all of these before the release of the update and everything’s there as it’s supposed to be. Instead of “not working”, I would appreciate it if you elaborate, post screenshots, videos of what’s happening and so on. I will record it myself to show both Unlimited Adrenaline and Damage Multiplier work.

L.E.: Here you go; proof that everything’s working on my end (UPlay version).

@cowboy44mag, @VitorCocenzo, @ozmoses2011, @DanFromDiscord

Are you all running the Steam version??? In which case that would explain it, as the ACOdyssey.exe might be different. On UPlay, as you’ve seen it, I have no issues.

Dear Ubisoft, if you’re reading this, don’t you think it’s about time you gave up compiling different executables for each platform you’ve sold the rights to publish your games? Thank you. - - SunBeam, a mere customer.


#901

When in game all the other cheats work perfectly. Before the update both Unlimited Adrenaline and Damage Multiplier worked as well. After the latest update while in game if you say push Numpad 3 to activate Unlimited Adrenaline it still makes the sound as if it is engaged, however where the Adrenaline bar use to immediately go to full and of course would stay there the bar remains where it is and if you use an ability the bar goes down just like normal game play. Basically it makes the sound as if its engaging but nothing actually happens it just remains normal and is not unlimited. The same is true for Damage Multiplier, the sounds will still be there, but in game it simply doesn’t do anything, the Damage Multiplier remains at default.

I am running an older version of the game, however before the latest update all the cheats were working perfectly for me. Is it possible to get a link or do a reinstall to be running the previous version of Wemod’s Odyssey trainer? By the way, you do awesome work.


#902

Considering the format in which UPlay games are delivered, whereas running old versions wouldn’t work as Denuvo has a timestamp trigger (even if you use Version Guard, it wouldn’t let you run an older version after a while) and the fact that no one in their right mind (having bought the official version) would skip a game update which brings new content, I can safely say you’re running a cracked version. That and the fact that my trainers for Ubisoft games will always be for the official version. That’s how I roll, my friend. Take it or leave it.

L.E.#1: One more thing I noticed is this: I appreciate all your warm comments and the appreciation itself of my work; but why is there a “but” after that? Like “I love your trainer but… -> can you do this, add that, etc.? Thanks!”

L.E.#2: Now that I’ve visited the all known location, I can safely assume everyone having reported the trainer not working after 1.1.2 update is running 1.05 version with unlocked DLC via an unlocker. Right? :smiley: Be honest.


#903

I got it working, I was indeed using Steam. As soon as I selected UPlay everything works again. Again, thank you for all you great work, and I didn’t mean any disrespect to you at all in any previous posts. Total respect for your work!!


#904

OK, make me understand one thing, please: have you bought both Steam and UPlay versions? Or you mean… you have chosen to run the UPlay trainer in the WeMod GUI, not the Steam trainer? o_O There is one trainer which should work identically for both Steam/UPlay. Your reply seems fishy to me, that’s why a clarification is important: do you own both versions, Steam and UPlay? :slight_smile:

L.E.#1:

“I am running an older version of the game, however before the latest update all the cheats were working perfectly for me.”

vs.

“I got it working, I was indeed using Steam.”

So which is it? :smiley: :smiley: Busted!

L.E.#2: Guess he gave up…
image

Out…


#905

Is it bad to play cracked version


#906

hey Sunbeam, thank you for the update. Cheers!


#907

I counted 4 replies over stuff not working. Out of those, 3 never reported back and 1 kinda tried to cover it up, as if playing unpaid-for versions of a game is a bad thing. So I’m pretty confident the latest update works as intended; till some 1.1.2 player indeed reports something I missed. So yeah, that’s that :slight_smile:

@Forkinator: You’re welcome, man! :slight_smile:


#908

Everything is working fine for the steam version.


#909

Thank you for confirming it! Alright: so, all in all, whoever’s running old, cracked/torrented versions, is going to complain stuff’s not working. Nice; ironed out :slight_smile: Peace out.


#910

Hey, it seems like the add ability point option isn’t working on the Steam version.


#911

It does work. Keep adding :slight_smile: Please read post #2 in this topic, bullet 7. Thanks!


#912

Oh okay, it’s working now. Thank you.


#913

Hello, just to report a problem, seems to me that the player damage multiplier doesn’t work, and it seems that the adrestia damage multiplier doens’t work neither.

Thanks a lot for your work


#914

Where is your copy of the game from? :slightly_smiling_face:


#915

Hi there. The trainer works just with version 1.1.2 of the game. Doesn’t support old versions for some of the options (several of them might work, if the scanned-for array is found for your version; others, like the ones you enumerated, won’t).